aboutsummaryrefslogtreecommitdiffstats
path: root/package/gpioctl/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2008-01-26 04:24:05 +0000
committerJohn Crispin <blogic@openwrt.org>2008-01-26 04:24:05 +0000
commitb6ed86f4c2bffe8807533c5300d81dd06bcb3213 (patch)
tree8995d076d8b2e07f68850ec8aa018b34044b1206 /package/gpioctl/Makefile
parent40bd451c8878fae2bc352ab80ebff64212ee5222 (diff)
downloadmaster-187ad058-b6ed86f4c2bffe8807533c5300d81dd06bcb3213.tar.gz
master-187ad058-b6ed86f4c2bffe8807533c5300d81dd06bcb3213.tar.bz2
master-187ad058-b6ed86f4c2bffe8807533c5300d81dd06bcb3213.zip
add userspace tool for gpio_dev
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10267 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/gpioctl/Makefile')
-rw-r--r--package/gpioctl/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/gpioctl/Makefile b/package/gpioctl/Makefile
new file mode 100644
index 0000000000..f288ec9150
--- /dev/null
+++ b/package/gpioctl/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=gpioctl
+PKG_RELEASE:=1
+PKG_VERSION:=1.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/gpioctl
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Tool for controlling gpio pins
+endef
+
+define Package/gpioctl/description
+ Tool for controlling gpio pins
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) CFLAGS="$(TARGET_CFLAGS) -I$(LINUX_DIR)/include"
+endef
+
+define Package/gpioctl/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/gpioctl $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,gpioctl))