aboutsummaryrefslogtreecommitdiffstats
path: root/package/fuse/patches-kernel24/101-kmod_build.patch
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-14 02:01:14 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-14 02:01:14 +0000
commitc77b6b564f2600619f32b3fc7266949083fecddc (patch)
treeacfa1a7237e42516ca3aa6f14ccc5344874b0508 /package/fuse/patches-kernel24/101-kmod_build.patch
parentef11d8626cc0b1bd642898647a6593467863a6c5 (diff)
downloadmaster-187ad058-c77b6b564f2600619f32b3fc7266949083fecddc.tar.gz
master-187ad058-c77b6b564f2600619f32b3fc7266949083fecddc.tar.bz2
master-187ad058-c77b6b564f2600619f32b3fc7266949083fecddc.zip
find attached the announced patch for fuse.
changes: - latest fuse 2.8.3 - includes now the kernel module for kernel 2.4 - builds parallel - fuse-utils includes now ulockmgr_server fuse24 should be deleted from trunk. bud git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20190 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/fuse/patches-kernel24/101-kmod_build.patch')
-rw-r--r--package/fuse/patches-kernel24/101-kmod_build.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/fuse/patches-kernel24/101-kmod_build.patch b/package/fuse/patches-kernel24/101-kmod_build.patch
new file mode 100644
index 0000000000..08cf0a8f73
--- /dev/null
+++ b/package/fuse/patches-kernel24/101-kmod_build.patch
@@ -0,0 +1,45 @@
+--- a/kernel/Makefile.in
++++ b/kernel/Makefile.in
+@@ -54,23 +54,8 @@ distdir: $(DISTFILES) $(COMPATDISTFILES)
+
+ ifeq ($(majver), 2.4)
+
+-CC = gcc
+-LD = ld
+-CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe @KERNELCFLAGS@
+-CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
+-
+ fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
+
+-SUFFIXES = .c .o .s
+-
+-all-spec: fuse.o
+-
+-.c.o:
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+-
+-fuse.o: $(fuse_objs)
+- $(LD) -r -o fuse.o $(fuse_objs)
+-
+ fuse_headers = fuse_i.h fuse_kernel.h
+
+ dev.o: $(fuse_headers)
+@@ -78,6 +63,18 @@ dir.o: $(fuse_headers)
+ file.o: $(fuse_headers)
+ inode.o: $(fuse_headers)
+
++EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
++
++O_TARGET := fuse.o
++
++obj-y := $(fuse_objs)
++obj-m := $(O_TARGET)
++
++-include $(TOPDIR)/Rules.make
++
++all-spec:
++ $(MAKE) -C @kernelsrc@ TOPDIR=@kernelsrc@ SUBDIRS=$(PWD) modules
++
+ else
+
+ EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"