aboutsummaryrefslogtreecommitdiffstats
path: root/package/fuse/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-05-11 22:27:32 +0000
committerNicolas Thill <nico@openwrt.org>2008-05-11 22:27:32 +0000
commit8b25dcbb4e1926fd13364469e25815847a26a233 (patch)
tree0590f3165acd178a0e0ad7175d5d0725d75eedbc /package/fuse/Makefile
parent2f18c70fb64b794976253267fd3dd6c693ae7799 (diff)
downloadmaster-187ad058-8b25dcbb4e1926fd13364469e25815847a26a233.tar.gz
master-187ad058-8b25dcbb4e1926fd13364469e25815847a26a233.tar.bz2
master-187ad058-8b25dcbb4e1926fd13364469e25815847a26a233.zip
fix fuse: use in-kernel module for 2.6.25+ kernels
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11116 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/fuse/Makefile')
-rw-r--r--package/fuse/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/package/fuse/Makefile b/package/fuse/Makefile
index 2376eaae33..5c013a7bc7 100644
--- a/package/fuse/Makefile
+++ b/package/fuse/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -48,11 +48,12 @@ $(call Package/fuse/Default)
SUBMENU:=Filesystems
DEPENDS:=@LINUX_2_6
TITLE+= (kernel module)
- FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
+ KCONFIG:= CONFIG_FUSE_FS
+ FILES:=$(LINUX_DIR)/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,80,fuse)
endef
-define Kernel/Package/fuse/description
+define KernelPackage/fuse/description
$(call Package/fuse/Default/description)
This package contains the FUSE kernel module.
endef
@@ -78,7 +79,6 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-rpath \
- --enable-kernel-module \
--enable-lib \
--enable-util \
--disable-example \
@@ -86,6 +86,17 @@ CONFIGURE_ARGS += \
--with-kernel="$(LINUX_DIR)" \
--disable-mtab
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,2.6.25)),1)
+ define KernelPackage/fuse/2.6
+ KCONFIG:=
+ FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
+ endef
+
+ CONFIGURE_ARGS += --enable-kernel-module
+else
+ CONFIGURE_ARGS += --disable-kernel-module
+endif
+
define Build/Configure
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
touch configure.in ; \