aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-21 16:00:32 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-21 16:00:32 +0200
commite5cbcbe736186d67b11ada76e0057259ca35e662 (patch)
tree657e46a9076dd5775e003c49b37b81883f05e867 /package/firmware
parent557ecbebe7216ba4f898bbc3fb45bdae818c06d5 (diff)
downloadmaster-187ad058-e5cbcbe736186d67b11ada76e0057259ca35e662.tar.gz
master-187ad058-e5cbcbe736186d67b11ada76e0057259ca35e662.tar.bz2
master-187ad058-e5cbcbe736186d67b11ada76e0057259ca35e662.zip
package: flag further target specific packages as nonshared
Add nonshared flag to package depending on specific targets or subtargets as there's no guarantee otherwise that they'll be available in the shared repo. [Edit: files modified in previous commit were removed from the list.] Signed-off-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/am33x-cm3/Makefile2
-rw-r--r--package/firmware/ixp4xx-microcode/Makefile2
-rw-r--r--package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile2
-rw-r--r--package/firmware/vsc73x5-ucode/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/package/firmware/am33x-cm3/Makefile b/package/firmware/am33x-cm3/Makefile
index bd7e2ae536..6f6d050013 100644
--- a/package/firmware/am33x-cm3/Makefile
+++ b/package/firmware/am33x-cm3/Makefile
@@ -20,6 +20,8 @@ PKG_MD5SUM:=40a6b7edae5e5cfff99bebde2bf20b97
PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+PKG_FLAGS:=nonshared
+
include $(INCLUDE_DIR)/package.mk
define Package/am33x-cm3
diff --git a/package/firmware/ixp4xx-microcode/Makefile b/package/firmware/ixp4xx-microcode/Makefile
index 1af12480c1..502424d678 100644
--- a/package/firmware/ixp4xx-microcode/Makefile
+++ b/package/firmware/ixp4xx-microcode/Makefile
@@ -15,6 +15,8 @@ PKG_SOURCE:=IPL_ixp400NpeLibraryWithCrypto-2_4.zip
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
PKG_MD5SUM:=dd5f6482e625ecb334469958bcd54b37
+PKG_FLAGS:=nonshared
+
include $(INCLUDE_DIR)/package.mk
define Package/ixp4xx-microcode
diff --git a/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile b/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile
index 7e94d49246..a39bf412de 100644
--- a/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile
+++ b/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile
@@ -14,6 +14,8 @@ PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_MD5SUM:=4c8d9ca68dda88d3cfc0ca0fb946a63e
PKG_BUILD_DEPENDS:=bsdiff/host
+PKG_FLAGS:=nonshared
+
include $(INCLUDE_DIR)/package.mk
PKG_B_NAME:=dsl_vr9_firmware_xdsl
diff --git a/package/firmware/vsc73x5-ucode/Makefile b/package/firmware/vsc73x5-ucode/Makefile
index 3a07121107..e3379a1f95 100644
--- a/package/firmware/vsc73x5-ucode/Makefile
+++ b/package/firmware/vsc73x5-ucode/Makefile
@@ -17,6 +17,8 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/vsc73x5-ucode
PKG_MD5SUM:=b32e3debcd118f263c79199a7b5afa68
+PKG_FLAGS:=nonshared
+
include $(INCLUDE_DIR)/package.mk
define Package/vsc73x5-defaults