aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-22 08:54:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-22 08:54:08 +0000
commit7d00e0c14f2ac50f6c72a0a6388d271ac87a85ed (patch)
tree552a6e655f061c46ced46b4a2eb0fe7239e470d1 /package/firmware
parentc1db676b0ddbaf9250756074ce316cfbb93aac9a (diff)
downloadmaster-187ad058-7d00e0c14f2ac50f6c72a0a6388d271ac87a85ed.tar.gz
master-187ad058-7d00e0c14f2ac50f6c72a0a6388d271ac87a85ed.tar.bz2
master-187ad058-7d00e0c14f2ac50f6c72a0a6388d271ac87a85ed.zip
mac80211: add packages libertas-spi module and firmware
This adds option to build kernel module and firmware packages for a Marvell 8686 SPI Wireless device Signed-off-by: Joseph Honold <mozzwald@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48750 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/marvell.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/marvell.mk b/package/firmware/linux-firmware/marvell.mk
index 86c0e6fede..752a8e0b4e 100644
--- a/package/firmware/linux-firmware/marvell.mk
+++ b/package/firmware/linux-firmware/marvell.mk
@@ -44,3 +44,13 @@ define Package/libertas-sdio-firmware/install
endef
$(eval $(call BuildPackage,libertas-sdio-firmware))
+Package/libertas-spi-firmware = $(call Package/firmware-default,Marvell 8686 SPI firmware)
+define Package/libertas-spi-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/libertas
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/libertas/gspi8686_v9_helper.bin \
+ $(PKG_BUILD_DIR)/libertas/gspi8686_v9.bin \
+ $(1)/lib/firmware/libertas
+endef
+$(eval $(call BuildPackage,libertas-spi-firmware))
+