aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-23 14:45:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-23 14:45:22 +0000
commit50940319d76c171d9a64ae4212226b3240303246 (patch)
treeb82d121d683bcab48317f38713ff1df4f56fd83e /package/firmware
parent1dc2e78612ffc45c7285fed3b2141170b237a292 (diff)
downloadmaster-187ad058-50940319d76c171d9a64ae4212226b3240303246.tar.gz
master-187ad058-50940319d76c171d9a64ae4212226b3240303246.tar.bz2
master-187ad058-50940319d76c171d9a64ae4212226b3240303246.zip
ath10k-firmware: Update QCA988X firmware to 10.2.4.97-1
Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47984 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 596cf1f808..882294cef3 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ath10k-firmware
-PKG_SOURCE_VERSION:=69f955c3dd95d97c7c30960aa5c9852c80b85cc3
+PKG_SOURCE_VERSION:=77f72b5f7dd940386d9e619a17904987759b7186
PKG_VERSION:=2014-11-13-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
@@ -37,6 +37,15 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA988x devices
endef
+QCA988X_FIRMWARE_FILE:=firmware-5.bin_10.2.4.97-1
+
+define Download/ath10k-firmware-qca988x
+ URL:=https://www.codeaurora.org/cgit/quic/qsdk/oss/firmware/ath10k-firmware/plain/10.2.4/
+ FILE:=$(QCA988X_FIRMWARE_FILE)
+ MD5SUM:=fcb2fbd42d73a63fbf603505c718cbde
+endef
+$(eval $(call Download,ath10k-firmware-qca988x))
+
define Package/ath10k-firmware-qca99x0
$(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA99x0 devices
@@ -68,7 +77,7 @@ define Package/ath10k-firmware-qca988x/install
$(PKG_BUILD_DIR)/QCA988X/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/QCA988X/10.2.4/firmware-5.bin_10.2.4.70.12-2 \
+ $(DL_DIR)/$(QCA988X_FIRMWARE_FILE) \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
endef