aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-10 12:03:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-10 12:03:39 +0000
commit01abaaf05e0244cd99f40826ae3e14c6c59c29c2 (patch)
tree822f14526cf63d6dd54aab4fd3fe5a5b628817d3 /package/firmware
parent66383f437326305e90d1dc414fba2d414bb41327 (diff)
downloadmaster-187ad058-01abaaf05e0244cd99f40826ae3e14c6c59c29c2.tar.gz
master-187ad058-01abaaf05e0244cd99f40826ae3e14c6c59c29c2.tar.bz2
master-187ad058-01abaaf05e0244cd99f40826ae3e14c6c59c29c2.zip
ath10k-firmware: add qca6174 firmware (mostly untested)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47437 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index ac95543867..6b694a6c36 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -23,25 +23,30 @@ include $(INCLUDE_DIR)/package.mk
WMENU:=Wireless Drivers
-define Package/ath10k-firmware-qca988x
+define Package/ath10k-firmware-default
SECTION:=kernel
CATEGORY:=Kernel modules
SUBMENU:=$(WMENU)
URL:=$(PKG_SOURCE_URL)
- DEFAULT:=PACKAGE_kmod-ath10k
DEPENDS:=kmod-ath10k
+endef
+
+define Package/ath10k-firmware-qca988x
+$(Package/ath10k-firmware-default)
+ DEFAULT:=PACKAGE_kmod-ath10k
TITLE:=ath10k firmware for QCA988x devices
endef
define Package/ath10k-firmware-qca99x0
- SECTION:=kernel
- CATEGORY:=Kernel modules
- SUBMENU:=$(WMENU)
- URL:=$(PKG_SOURCE_URL)
- DEPENDS:=kmod-ath10k
+$(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA99x0 devices
endef
+define Package/ath10k-firmware-qca6174
+$(Package/ath10k-firmware-default)
+ TITLE:=ath10k firmware for QCA6174 devices
+endef
+
define Build/Compile
endef
@@ -56,6 +61,11 @@ define Package/ath10k-firmware-qca988x/install
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
endef
+define Package/ath10k-firmware-qca6174/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k
+ $(CP) $(PKG_BUILD_DIR)/ath10k/QCA6174 $(1)/lib/firmware/ath10k/
+endef
+
define Package/ath10k-firmware-qca99x0/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA99X0/hw2.0
$(INSTALL_DATA) \
@@ -68,3 +78,4 @@ endef
$(eval $(call BuildPackage,ath10k-firmware-qca988x))
$(eval $(call BuildPackage,ath10k-firmware-qca99x0))
+$(eval $(call BuildPackage,ath10k-firmware-qca6174))