aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2008-08-04 11:51:58 +0000
committerJohn Crispin <blogic@openwrt.org>2008-08-04 11:51:58 +0000
commit275038cae7e3e363c1e0062d0639749178659a8b (patch)
tree366e67ab18afcef24dc1dfd1f5fb39eb7484275f /package/firewall/Makefile
parent8ffee3956dc468134bb14f47a7c82f248b9671ff (diff)
downloadmaster-187ad058-275038cae7e3e363c1e0062d0639749178659a8b.tar.gz
master-187ad058-275038cae7e3e363c1e0062d0639749178659a8b.tar.bz2
master-187ad058-275038cae7e3e363c1e0062d0639749178659a8b.zip
adds a new uci firewall
- iptbales and netfilter packages need to be rewrapped when we switch to this firewall as default - there are some examples in the file /etc/config/firewall - iptables-save/restore are still missing - hotplug takes care of adding/removing netdevs during runtime - misisng features ? wishes ? let me know ... git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12089 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall/Makefile')
-rw-r--r--package/firewall/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
new file mode 100644
index 0000000000..e073b5771c
--- /dev/null
+++ b/package/firewall/Makefile
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=firewall
+
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/firewall
+ SECTION:=net
+ CATEGORY:=Base system
+ URL:=http://openwrt.org/
+ TITLE:=OpenWrt firewall
+ DEPENDS:=+iptables
+endef
+
+define Package/firewall/description
+ firewall for openwrt, you can select if you want to use the old version or the new uci based script
+endef
+
+define Package/firewall/config
+ source "$(SOURCE)/Config.in"
+endef
+
+define Build/Compile
+ true
+endef
+
+ifeq ($(CONFIG_FIREWALL_NEW),y)
+define Package/firewall/conffiles
+/etc/config/firewall
+endef
+
+define Package/firewall/install
+ $(INSTALL_DIR) $(1)/lib/firewall
+ $(INSTALL_DATA) ./files/new/uci_firewall.sh $(1)/lib/firewall
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./files/new/firewall.config $(1)/etc/config/firewall
+ $(INSTALL_DIR) $(1)/etc/init.d/
+ $(INSTALL_BIN) ./files/new/firewall.init $(1)/etc/init.d/firewall
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/new/20-firewall $(1)/etc/hotplug.d/iface
+endef
+
+else
+
+define Package/firewall/conffiles
+/etc/firewall.config
+/etc/firewall.user
+endef
+
+define Package/firewall/install
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./files/old/firewall.config $(1)/etc/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/old/firewall.init $(1)/etc/init.d/firewall
+ $(INSTALL_BIN) ./files/old/firewall.user $(1)/etc/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_DATA) ./files/old/firewall.awk $(1)/usr/lib
+endef
+endif
+$(eval $(call BuildPackage,firewall))