aboutsummaryrefslogtreecommitdiffstats
path: root/package/e2fsprogs/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-02-02 01:29:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-02-02 01:29:32 +0000
commitcdd9cb603f997f7d9c861a7ec2409c8ccf8e5695 (patch)
tree413f8a88a2813213282d2a25e8c4787718603e6a /package/e2fsprogs/Makefile
parentf89ca7d9e3b0aa1d542195aa7b8d136a0683e439 (diff)
downloadmaster-187ad058-cdd9cb603f997f7d9c861a7ec2409c8ccf8e5695.tar.gz
master-187ad058-cdd9cb603f997f7d9c861a7ec2409c8ccf8e5695.tar.bz2
master-187ad058-cdd9cb603f997f7d9c861a7ec2409c8ccf8e5695.zip
package uuidgen
Package uuidgen utility. It is useful for other filesystem utilities and miniupnpd. There is no need to change the release. Signed-off-by: Lubos Stanek (lubek) <lubek@lubek.name> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10350 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/e2fsprogs/Makefile')
-rw-r--r--package/e2fsprogs/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index f93cf4acca..a30aea7ed8 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -47,6 +47,19 @@ define Package/libuuid/description
Library for generating DCE compatible Universally Unique Identifiers.
endef
+define Package/uuidgen
+$(call Package/e2fsprogs)
+ DEPENDS:=libuuid
+ TITLE:=Command line utility to create a new UUID value
+endef
+
+define Package/uuidgen/description
+ uuidgen program creates a new universally unique identifier (UUID)
+ using the libuuid library. The new UUID can reasonably be considered
+ unique among all UUIDs created on the local system, and among UUIDs
+ created on other systems in the past and in the future.
+endef
+
define Package/libblkid
$(call Package/e2fsprogs/Default)
SECTION:=libs
@@ -118,6 +131,11 @@ define Package/libuuid/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libuuid.so.* $(1)/usr/lib/
endef
+define Package/uuidgen/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uuidgen $(1)/usr/bin/
+endef
+
define Package/libblkid/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
@@ -135,6 +153,7 @@ endef
$(eval $(call BuildPackage,e2fsprogs))
$(eval $(call BuildPackage,libuuid))
+$(eval $(call BuildPackage,uuidgen))
$(eval $(call BuildPackage,libblkid))
$(eval $(call BuildPackage,tune2fs))
$(eval $(call BuildPackage,resize2fs))