aboutsummaryrefslogtreecommitdiffstats
path: root/package/diag/src/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-06-18 13:04:58 +0000
committerNicolas Thill <nico@openwrt.org>2006-06-18 13:04:58 +0000
commit92d8adc75d1e9f04f9dde8eb17520ace27d384f6 (patch)
tree529d728be361cd59f77b2bf6a6e71da21cedb0ed /package/diag/src/Makefile
parentf4b5800480aa3d75594bb936b6bbba4778537ea2 (diff)
downloadmaster-187ad058-92d8adc75d1e9f04f9dde8eb17520ace27d384f6.tar.gz
master-187ad058-92d8adc75d1e9f04f9dde8eb17520ace27d384f6.tar.bz2
master-187ad058-92d8adc75d1e9f04f9dde8eb17520ace27d384f6.zip
move source files to src/ and let the kernel tree build the module.
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3981 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/diag/src/Makefile')
-rw-r--r--package/diag/src/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/diag/src/Makefile b/package/diag/src/Makefile
new file mode 100644
index 0000000000..169f2e9725
--- /dev/null
+++ b/package/diag/src/Makefile
@@ -0,0 +1,19 @@
+# $Id$
+#
+# Makefile for diag driver
+#
+# Copyright (C) 2005 Felix Fietkau <nbd@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+obj-m := diag.o
+
+ifeq ($(MAKING_MODULES),1)
+export-objs := diag.o
+
+-include $(TOPDIR)/Rules.make
+endif