aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-02 14:47:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-02 14:47:48 +0000
commitbc33de524ebe39f357f15ca497701bb2dd9b38ca (patch)
tree5301e8808b355fc8f118a372d5da0ace129debf5 /package/devel
parent0a3f396665a65b5518a6740f8d5f2ee7213bb009 (diff)
downloadmaster-187ad058-bc33de524ebe39f357f15ca497701bb2dd9b38ca.tar.gz
master-187ad058-bc33de524ebe39f357f15ca497701bb2dd9b38ca.tar.bz2
master-187ad058-bc33de524ebe39f357f15ca497701bb2dd9b38ca.zip
perf: fix parallel build support, explicitly disable more library dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48066 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index c03b9330f4..d6db053173 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -13,6 +13,7 @@ PKG_VERSION:=$(LINUX_VERSION)
PKG_RELEASE:=2
PKG_USE_MIPS16:=0
+PKG_BUILD_PARALLEL:=1
# Perf's makefile and headers are not relocatable and must be built from the
# Linux sources directory
@@ -43,15 +44,26 @@ MAKE_FLAGS = \
NO_LIBPYTHON=1 \
NO_NEWT=1 \
NO_LZMA=1 \
+ NO_BACKTRACE=1 \
+ NO_LIBNUMA=1 \
+ NO_GTK2=1 \
+ NO_LIBAUDIT=1 \
CROSS_COMPILE="$(TARGET_CROSS)" \
CC="$(TARGET_CC)" \
LD="$(TARGET_CROSS)ld" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
+ $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
WERROR=0 \
- V=1 \
prefix=/usr
+define Build/Compile
+ +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
+ -C $(PKG_BUILD_DIR) \
+ -f Makefile.perf \
+ --no-print-directory
+endef
+
define Package/perf/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/perf $(1)/usr/bin/