aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-30 11:02:22 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-30 11:02:22 +0000
commitb308ce739e42ec2afffa12924787ded8480ccbd8 (patch)
treebfd366608e8ee56ccc60aa8d67fe6dcf3901278e /package/devel
parent3651b3452d3e7d83df558edc31ba892cb0c40c3b (diff)
downloadmaster-187ad058-b308ce739e42ec2afffa12924787ded8480ccbd8.tar.gz
master-187ad058-b308ce739e42ec2afffa12924787ded8480ccbd8.tar.bz2
master-187ad058-b308ce739e42ec2afffa12924787ded8480ccbd8.zip
binutils: link libbfd and libopcodes dynamically again
Build libbfd and libopcodes as shared libraries, else they get linked statically into every binary, increasing each binary size by ~650kB. Reduces binutils package size to old expected values. Fixes #17060. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42337 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/binutils/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index a88b5d1724..e8d45d2d8b 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
PKG_VERSION:=2.24
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@GNU/binutils
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -48,6 +48,7 @@ endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
+ --enable-shared \
--enable-install-libiberty \
--enable-install-libbfd
@@ -67,6 +68,8 @@ endef
define Package/objdump/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/bin/objdump $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopcodes*.so $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so $(1)/usr/lib/
endef
define Package/binutils/install