aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-07 16:02:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-07 16:02:59 +0000
commita036637af6363b03ca8b3af8deade1baa534947c (patch)
tree59810a268809e75e53e7f09844f21977506357f8 /package/devel
parent0ed789a6ab8ce25e956699cc15790c2fbcac47e8 (diff)
downloadmaster-187ad058-a036637af6363b03ca8b3af8deade1baa534947c.tar.gz
master-187ad058-a036637af6363b03ca8b3af8deade1baa534947c.tar.bz2
master-187ad058-a036637af6363b03ca8b3af8deade1baa534947c.zip
package/binutils: actually support the target toolchain
This fixes a bug, where ld on ARM EABI platforms expects OABI code. Signed-off-by: Harald Geyer <harald@ccbib.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/binutils/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index cf7769013c..c5a0717477 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -69,6 +69,8 @@ endef
TARGET_CFLAGS += $(FPIC) -Wno-unused-value
CONFIGURE_ARGS += \
+ --host=$(REAL_GNU_TARGET_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
--enable-shared \
--enable-install-libiberty \
--enable-install-libbfd