aboutsummaryrefslogtreecommitdiffstats
path: root/package/cups
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-11 01:35:26 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-11 01:35:26 +0000
commit400e21ab5e867dca9b4325f0e9d0e2f609c271e5 (patch)
treec5316f6a52a63d1535003907f8df4946c9f17e1f /package/cups
parentc3824ca7aaef9f5c4731fdb4379f039464adb900 (diff)
downloadmaster-187ad058-400e21ab5e867dca9b4325f0e9d0e2f609c271e5.tar.gz
master-187ad058-400e21ab5e867dca9b4325f0e9d0e2f609c271e5.tar.bz2
master-187ad058-400e21ab5e867dca9b4325f0e9d0e2f609c271e5.zip
Fix cups install
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/cups')
-rw-r--r--package/cups/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/cups/Makefile b/package/cups/Makefile
index 33f283574f..237773f8b9 100644
--- a/package/cups/Makefile
+++ b/package/cups/Makefile
@@ -90,10 +90,14 @@ $(PKG_IPK): $(PKG_IPK_DIR)/usr/sbin/cupsd
find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+ $(IPKG) install $(PKG_IPK)
+
source: $(DL_DIR)/$(PKG_SOURCE)
prepare: $(PKG_BUILD_DIR)/.patched
compile: $(PKG_IPK)
-install:
- $(IPKG) install $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IPK)