aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-03-03 20:35:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-03-03 20:35:01 +0000
commitfaa289d9853f62f5c0b8084902e26a121ee8a03b (patch)
tree5ff00962fbf954332a4f650b3cb36a4aaa7d60bf /package/busybox
parent69aa065a6b80b4dc9df44a5f3d165e6f17269e81 (diff)
downloadmaster-187ad058-faa289d9853f62f5c0b8084902e26a121ee8a03b.tar.gz
master-187ad058-faa289d9853f62f5c0b8084902e26a121ee8a03b.tar.bz2
master-187ad058-faa289d9853f62f5c0b8084902e26a121ee8a03b.zip
R.I.P. devfs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6478 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile1
-rw-r--r--package/busybox/config/miscutils/Config.in2
-rw-r--r--package/busybox/config/util-linux/Config.in4
-rw-r--r--package/busybox/target-config.in11
4 files changed, 15 insertions, 3 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 530b027670..3e6cc4e9c9 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -41,6 +41,7 @@ The Swiss Army Knife of embedded Linux.
endef
define Package/busybox/config
+ source "$(SOURCE)/target-config.in"
menu "Configuration"
depends on PACKAGE_busybox
source "$(SOURCE)/config/Config.in"
diff --git a/package/busybox/config/miscutils/Config.in b/package/busybox/config/miscutils/Config.in
index 41a42c91a1..4e418893f4 100644
--- a/package/busybox/config/miscutils/Config.in
+++ b/package/busybox/config/miscutils/Config.in
@@ -105,7 +105,7 @@ config BUSYBOX_CONFIG_DEVFSD_VERBOSE
config BUSYBOX_CONFIG_FEATURE_DEVFS
bool " Use devfs names for all devices (obsolete)"
- default y
+ default n
help
This is obsolete and will be going away at the end of 2008..
diff --git a/package/busybox/config/util-linux/Config.in b/package/busybox/config/util-linux/Config.in
index ab3dc3731d..0f219d70e2 100644
--- a/package/busybox/config/util-linux/Config.in
+++ b/package/busybox/config/util-linux/Config.in
@@ -267,7 +267,7 @@ config BUSYBOX_CONFIG_LOSETUP
config BUSYBOX_CONFIG_MDEV
bool "mdev"
- default n
+ default y
help
mdev is a mini-udev implementation: call it with -s to populate
/dev from /sys, then "echo /sbin/mdev > /proc/sys/kernel/hotplug" to
@@ -276,7 +276,7 @@ config BUSYBOX_CONFIG_MDEV
config BUSYBOX_CONFIG_FEATURE_MDEV_CONF
bool "Support /etc/mdev.conf"
- default n
+ default y
depends on BUSYBOX_CONFIG_MDEV
help
The mdev config file contains lines that look like:
diff --git a/package/busybox/target-config.in b/package/busybox/target-config.in
new file mode 100644
index 0000000000..77c58cef14
--- /dev/null
+++ b/package/busybox/target-config.in
@@ -0,0 +1,11 @@
+config BUSYBOX_CONFIG_FEATURE_DEVFS
+ default y if LINUX_2_4
+ default n if LINUX_2_6
+
+config BUSYBOX_CONFIG_MDEV
+ default n if LINUX_2_4
+ default y if LINUX_2_6
+
+config BUSYBOX_CONFIG_FEATURE_MDEV_CONF
+ default n if LINUX_2_4
+ default y if LINUX_2_6