aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-04 16:11:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-04 16:11:28 +0000
commit316ec36d07623583930130e0ccf0858bdc59b081 (patch)
tree9e9d1f708112b9a82a58b28744e943fd7c366950 /package/busybox
parent8eee721db6011ac50373466a0ed0c0528b99515c (diff)
downloadmaster-187ad058-316ec36d07623583930130e0ccf0858bdc59b081.tar.gz
master-187ad058-316ec36d07623583930130e0ccf0858bdc59b081.tar.bz2
master-187ad058-316ec36d07623583930130e0ccf0858bdc59b081.zip
replace gen_busybox_config.pl with a simple sed command
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6864 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 90e3af060a..03a0ebd549 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -51,7 +51,7 @@ endef
define Build/Configure
rm -f $(PKG_BUILD_DIR)/.configured*
- $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+ grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \