aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-13 02:52:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-13 02:52:34 +0000
commit2b98d239d2369aa362b59b23102a26fbd859d7ee (patch)
tree849f3f6a4e6fa4d711d2767d374d57fa1c3efa83 /package/busybox
parent4613711c4f9e7b5a4f3690636cf8852a01574030 (diff)
downloadmaster-187ad058-2b98d239d2369aa362b59b23102a26fbd859d7ee.tar.gz
master-187ad058-2b98d239d2369aa362b59b23102a26fbd859d7ee.tar.bz2
master-187ad058-2b98d239d2369aa362b59b23102a26fbd859d7ee.zip
busybox: fix compile with librpc if necessary (required by nfs mount support)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25507 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index d30be0de75..f4095c73c9 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=a2ce1a951571da8c6e0eaf75b1acef60
+PKG_BUILD_DEPENDS:=librpc
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -36,6 +37,7 @@ define Package/busybox
MAINTAINER:=Nicolas Thill <nico@openwrt.org>
TITLE:=Core utilities for embedded Linux
URL:=http://busybox.net/
+ DEPENDS:=+BUSYBOX_CONFIG_FEATURE_HAVE_RPC&&USE_UCLIBC:librpc
MENU:=1
endef
@@ -63,6 +65,13 @@ ifdef CONFIG_GCC_VERSION_LLVM
TARGET_CFLAGS += -fnested-functions
endif
+LDLIBS:=m crypt
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_HAVE_RPC
+ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+ export LDFLAGS=$(TARGET_LDFLAGS)
+ LDLIBS += rpc
+endif
+
define Build/Compile
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
@@ -71,6 +80,7 @@ define Build/Compile
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
SKIP_STRIP=y \
+ LDLIBS="$(LDLIBS)" \
all
rm -rf $(PKG_INSTALL_DIR)
$(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -80,6 +90,7 @@ define Build/Compile
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
+ LDLIBS="$(LDLIBS)" \
install
endef