aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-04 01:31:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-04 01:31:03 +0000
commit00b8251de565fdf42b2cd3625c767c7adb2b0041 (patch)
tree00d40dee12da87e40483d21ae6e48e5e99c42c25 /package/busybox
parent1c9db9d96f3fdfe258abfb826a567910a0076f03 (diff)
downloadmaster-187ad058-00b8251de565fdf42b2cd3625c767c7adb2b0041.tar.gz
master-187ad058-00b8251de565fdf42b2cd3625c767c7adb2b0041.tar.bz2
master-187ad058-00b8251de565fdf42b2cd3625c767c7adb2b0041.zip
don't compile libipkg in busybox if ipkg is disabled
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3901 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/patches/911-ipkg.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/busybox/patches/911-ipkg.patch b/package/busybox/patches/911-ipkg.patch
index 7b6437c98c..1d7a4e3574 100644
--- a/package/busybox/patches/911-ipkg.patch
+++ b/package/busybox/patches/911-ipkg.patch
@@ -203,16 +203,16 @@ diff -ruN busybox-1.1.2-orig/archival/libipkg/Makefile.in busybox-1.1.2+ipkg-0.9
+ str_util.c \
+ xsystem.c \
+
-+LIBIPKG-y += $(LIBIPKG_CORE_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_CMD_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_DB_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_LIST_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_UTIL_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CORE_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CMD_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_DB_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_LIST_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_UTIL_SOURCES)
+LIBIPKG_OBJS=$(patsubst %.c,$(LIBIPKG_DIR)%.o, $(LIBIPKG-y))
+
+CFLAGS += -DIPKG_LIB -DIPKGLIBDIR="\"/usr/lib\"" -DHOST_CPU_STR="\"$(TARGET_ARCH)\""
+
-+libraries-y += $(LIBIPKG_DIR)$(LIBIPKG_AR)
++libraries-$(CONFIG_IPKG) += $(LIBIPKG_DIR)$(LIBIPKG_AR)
+
+$(LIBIPKG_DIR)$(LIBIPKG_AR): $(LIBIPKG_OBJS)
+ $(do_ar)