aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-12-30 19:35:58 +0000
committerNicolas Thill <nico@openwrt.org>2006-12-30 19:35:58 +0000
commit924b7ef598953446ffdd6efbc1c65366af83c30c (patch)
tree9521f2dc4c564fddfdc5ee8aaed16ec54dfa93bb /package/busybox/Makefile
parent4a0a4aedb6af93af443bd9759712de4ff85f8f7f (diff)
downloadmaster-187ad058-924b7ef598953446ffdd6efbc1c65366af83c30c.tar.gz
master-187ad058-924b7ef598953446ffdd6efbc1c65366af83c30c.tar.bz2
master-187ad058-924b7ef598953446ffdd6efbc1c65366af83c30c.zip
update busybox to v1.3.1, i was too lazy to update patch 320, feel free to do so
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5941 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 0c1efc470a..2688777c00 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
-PKG_VERSION:=1.2.1
+PKG_VERSION:=1.3.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads
-PKG_MD5SUM:=362b3dc0f2023ddfda901dc1f1a74391
+PKG_MD5SUM:=571531cfa83726947ccb566de017ad4f
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -50,15 +50,17 @@ define Build/Configure
$(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
- CROSS="$(TARGET_CROSS)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ ARCH="$(ARCH)" \
oldconfig
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
- CROSS="$(TARGET_CROSS)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
all
endef
@@ -66,10 +68,11 @@ endef
define Package/busybox/install
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
- CROSS="$(TARGET_CROSS)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
- PREFIX="$(1)" \
+ CONFIG_PREFIX="$(1)" \
install
mkdir -p $(1)/etc/init.d
for tmp in $(init-y); do \