aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-10-08 13:10:10 +0000
committerNicolas Thill <nico@openwrt.org>2006-10-08 13:10:10 +0000
commit3f5404494c83b857ba79f36a7f62e9c79e2e1e2c (patch)
tree52eedd849955da0f2909db24e143bbdcdf8015bf /package/busybox/Makefile
parentc845c92e71cbb01f54303aa2375e381ff0a055ff (diff)
downloadmaster-187ad058-3f5404494c83b857ba79f36a7f62e9c79e2e1e2c.tar.gz
master-187ad058-3f5404494c83b857ba79f36a7f62e9c79e2e1e2c.tar.bz2
master-187ad058-3f5404494c83b857ba79f36a7f62e9c79e2e1e2c.zip
fix unknown arch in ipkg: use our ARCH instead of busybox's TARGET_ARCH (closes: #689)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4959 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 9e30492e90..c87701ad1e 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -46,11 +46,21 @@ define Build/Configure
oldconfig
endef
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CROSS="$(TARGET_CROSS)" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ IPKG_ARCH="$(ARCH)" \
+ all
+endef
+
define Package/busybox/install
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS="$(TARGET_CROSS)" \
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ IPKG_ARCH="$(ARCH)" \
PREFIX="$(1)" \
install
-rm -rf $(1)/lib64