aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-11 18:17:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-11 18:17:08 +0000
commit0bde423aa5ea20a7a506130edfab6f2a380aaa77 (patch)
tree2a9a5bc15bdaaeca05f9c9cf935c61368a4927ad /package/busybox/Makefile
parent19fc1973158ca8ea9482238cfaf4e9be0b499b23 (diff)
downloadmaster-187ad058-0bde423aa5ea20a7a506130edfab6f2a380aaa77.tar.gz
master-187ad058-0bde423aa5ea20a7a506130edfab6f2a380aaa77.tar.bz2
master-187ad058-0bde423aa5ea20a7a506130edfab6f2a380aaa77.zip
replace libcgi with some code extracted from haserl - libcgi is too inflexible and breaks rrdtool
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6554 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index eae037aaaa..cf6ddac6ec 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -19,7 +19,7 @@ PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=libcgi
+PKG_BUILD_DEPENDS:=gcgi
include $(INCLUDE_DIR)/package.mk
@@ -62,10 +62,9 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
- EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
all
endef
@@ -73,11 +72,10 @@ define Package/busybox/install
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
CONFIG_PREFIX="$(1)" \
- EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
install
$(INSTALL_DIR) $(1)/etc/init.d
for tmp in $(init-y); do \