aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-57xx/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-24 00:08:08 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-24 00:08:08 +0000
commit8ae9e2cf0fa0d71682948bb7ba341c07269c1618 (patch)
tree4c81f1a0e5b29b15d3f52653d6b1b8aff729b977 /package/broadcom-57xx/Makefile
parent6ef71d6d6c8be2d605cba94a75c54cfd904afcad (diff)
downloadmaster-187ad058-8ae9e2cf0fa0d71682948bb7ba341c07269c1618.tar.gz
master-187ad058-8ae9e2cf0fa0d71682948bb7ba341c07269c1618.tar.bz2
master-187ad058-8ae9e2cf0fa0d71682948bb7ba341c07269c1618.zip
[package] replace some -I & -L flags with $(TARGET_CPPFLAGS) & $(TARGET_LDFLAGS) when appropriate
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14651 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/broadcom-57xx/Makefile')
-rw-r--r--package/broadcom-57xx/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/broadcom-57xx/Makefile b/package/broadcom-57xx/Makefile
index 172074ca35..ddbea7894f 100644
--- a/package/broadcom-57xx/Makefile
+++ b/package/broadcom-57xx/Makefile
@@ -28,9 +28,10 @@ define Build/Prepare
endef
ifeq ($(BOARD),brcm-2.4)
- BUILDFLAGS = -DBCMDRIVER -I$(LINUX_DIR)/arch/mips/bcm947xx/include -I$(STAGING_DIR)/usr/include
- BUILDFLAGS += -DDBG=0 -DBCM_PROC_FS=1 -DT3_JUMBO_RCV_RCB_ENTRY_COUNT=256 -DNICE_SUPPORT
- BUILDFLAGS += -DPCIX_TARGET_WORKAROUND=1 -DINCLUDE_TBI_SUPPORT=1 -DINCLUDE_5701_AX_FIX=1
+ BUILDFLAGS := \
+ -DBCMDRIVER -I$(LINUX_DIR)/arch/mips/bcm947xx/include $(TARGET_CPPFLAGS) \
+ -DDBG=0 -DBCM_PROC_FS=1 -DT3_JUMBO_RCV_RCB_ENTRY_COUNT=256 -DNICE_SUPPORT \
+ -DPCIX_TARGET_WORKAROUND=1 -DINCLUDE_TBI_SUPPORT=1 -DINCLUDE_5701_AX_FIX=1
endif
define Build/Compile