aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-12-28 04:56:33 +0000
committerLuka Perkov <luka@openwrt.org>2015-12-28 04:56:33 +0000
commit1ae6ddc7737aae03093460df78f0e937d7935ce2 (patch)
tree7f186f45c10482a520e8c4ccd0af33c120d90a91 /package/boot
parentde0e562a757494ef9256682eaba9442334ae341a (diff)
downloadmaster-187ad058-1ae6ddc7737aae03093460df78f0e937d7935ce2.tar.gz
master-187ad058-1ae6ddc7737aae03093460df78f0e937d7935ce2.tar.bz2
master-187ad058-1ae6ddc7737aae03093460df78f0e937d7935ce2.zip
uboot-imx6: add support for i.MX6q SABRE board
U-boot ships with the `mx6qsabresd` configuration file to configure a bootloader suitable for booting the Freescale i.MX6q SABRE evaluation board from SD card. Expose this option in the uboot-imx6 Makefile. Signed-off-by: Keno Fischer <keno@juliacomputing.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48014 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-imx6/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 7074da9f0d..1e926238d8 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -28,6 +28,10 @@ define uboot/Default
IMAGE:=
endef
+define uboot/mx6qsabresd
+ TITLE:=U-Boot for SABRE i.MX6Quad board
+endef
+
define uboot/nitrogen6dl
TITLE:=U-Boot for Nitrogen6x i.MX6Dual-Lite 1GB board
endef
@@ -65,6 +69,7 @@ define uboot/wandboard_solo
endef
UBOOTS := \
+ mx6qsabresd \
nitrogen6dl \
nitrogen6dl2g \
nitrogen6q \