aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-11-19 14:43:16 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-11-19 14:43:16 +0000
commita700aef7e56f0cd9150b9e4e23d5e3747bc68b00 (patch)
treee1ef7a24c141bcfd62f32e33d18a8417383405d1 /package/boot/uboot-sunxi
parent8abfd4e47c66aebddc7036be31ad3440ee7749ba (diff)
downloadmaster-187ad058-a700aef7e56f0cd9150b9e4e23d5e3747bc68b00.tar.gz
master-187ad058-a700aef7e56f0cd9150b9e4e23d5e3747bc68b00.tar.bz2
master-187ad058-a700aef7e56f0cd9150b9e4e23d5e3747bc68b00.zip
packages: uboot-sunxi: update Lamobo R1 patch
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47516 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff362
1 files changed, 185 insertions, 177 deletions
diff --git a/package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff b/package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff
index 5dd816c1a1..0f7196fc11 100644
--- a/package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff
+++ b/package/boot/uboot-sunxi/patches/002-add-lamobo-r1.diff
@@ -1,18 +1,22 @@
-diff -ruN old/arch/arm/dts/Makefile new/arch/arm/dts/Makefile
---- old/arch/arm/dts/Makefile 2015-07-14 19:32:21.000000000 +0200
-+++ new/arch/arm/dts/Makefile 2015-07-31 23:23:33.518767858 +0200
-@@ -107,6 +107,7 @@
+diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
+index 9c735c6..a32d772 100644
+--- a/arch/arm/dts/Makefile
++++ b/arch/arm/dts/Makefile
+@@ -103,6 +103,7 @@ dtb-$(CONFIG_MACH_SUN7I) += \
+ sun7i-a20-ainol-aw1.dtb \
+ sun7i-a20-bananapi.dtb \
+ sun7i-a20-bananapro.dtb \
++ sun7i-a20-lamobo-r1.dtb \
+ sun7i-a20-cubieboard2.dtb \
sun7i-a20-cubietruck.dtb \
sun7i-a20-hummingbird.dtb \
- sun7i-a20-i12-tvbox.dtb \
-+ sun7i-a20-lamobo-r1.dtb \
- sun7i-a20-m3.dtb \
- sun7i-a20-m5.dtb \
- sun7i-a20-mk808c.dtb \
-diff -ruN old/arch/arm/dts/sun7i-a20-lamobo-r1.dts new/arch/arm/dts/sun7i-a20-lamobo-r1.dts
---- old/arch/arm/dts/sun7i-a20-lamobo-r1.dts 1970-01-01 01:00:00.000000000 +0100
-+++ new/arch/arm/dts/sun7i-a20-lamobo-r1.dts 2015-07-31 23:19:30.811206714 +0200
-@@ -0,0 +1,239 @@
+diff --git a/arch/arm/dts/sun7i-a20-lamobo-r1.dts
+b/arch/arm/dts/sun7i-a20-lamobo-r1.dts
+new file mode 100644
+index 0000000..a77fb5c
+--- /dev/null
++++ b/arch/arm/dts/sun7i-a20-lamobo-r1.dts
+@@ -0,0 +1,231 @@
+/*
+ * Copyright 2014 Hans de Goede <hdegoede@redhat.com>
+ *
@@ -33,11 +37,6 @@ diff -ruN old/arch/arm/dts/sun7i-a20-lamobo-r1.dts new/arch/arm/dts/sun7i-a20-la
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
-+ * You should have received a copy of the GNU General Public
-+ * License along with this file; if not, write to the Free
-+ * Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
-+ * MA 02110-1301 USA
-+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
@@ -71,8 +70,8 @@ diff -ruN old/arch/arm/dts/sun7i-a20-lamobo-r1.dts new/arch/arm/dts/sun7i-a20-la
+#include <dt-bindings/pinctrl/sun4i-a10.h>
+
+/ {
-+ model = "Lamobo R1";
-+ compatible = "lamobo,lamobo-r1", "allwinner,sun7i-a20";
++ model = "Lamobo Banana Pi R1";
++ compatible = "lemaker,bananapi", "allwinner,sun7i-a20";
+
+ aliases {
+ serial0 = &uart0;
@@ -80,198 +79,207 @@ diff -ruN old/arch/arm/dts/sun7i-a20-lamobo-r1.dts new/arch/arm/dts/sun7i-a20-la
+ serial2 = &uart7;
+ };
+
-+ soc@01c00000 {
-+ spi0: spi@01c05000 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&spi0_pins_a>;
-+ status = "okay";
-+ };
++ chosen {
++ stdout-path = "serial0:115200n8";
++ };
+
-+ mmc0: mmc@01c0f000 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&mmc0_pins_a>, <&mmc0_cd_pin_bananapi>;
-+ vmmc-supply = <&reg_vcc3v3>;
-+ bus-width = <4>;
-+ cd-gpios = <&pio 7 10 0>; /* PH10 */
-+ cd-inverted;
-+ status = "okay";
-+ };
++ leds {
++ compatible = "gpio-leds";
++ pinctrl-names = "default";
++ pinctrl-0 = <&led_pins_bananapi>;
+
-+ usbphy: phy@01c13400 {
-+ usb1_vbus-supply = <&reg_usb1_vbus>;
-+ usb2_vbus-supply = <&reg_usb2_vbus>;
-+ status = "okay";
++ green {
++ label = "bananapi:green:usr";
++ gpios = <&pio 7 24 GPIO_ACTIVE_HIGH>;
+ };
++ };
+
-+ ehci0: usb@01c14000 {
-+ status = "okay";
-+ };
++ reg_gmac_3v3: gmac-3v3 {
++ compatible = "regulator-fixed";
++ pinctrl-names = "default";
++ pinctrl-0 = <&gmac_power_pin_bananapi>;
++ regulator-name = "gmac-3v3";
++ regulator-min-microvolt = <3300000>;
++ regulator-max-microvolt = <3300000>;
++ startup-delay-us = <100000>;
++ enable-active-high;
++ gpio = <&pio 7 23 GPIO_ACTIVE_HIGH>;
++ };
++};
+
-+ ohci0: usb@01c14400 {
-+ status = "okay";
-+ };
++&ahci {
++ status = "okay";
++};
+
-+ ahci: sata@01c18000 {
-+ status = "okay";
-+ };
++&ehci0 {
++ status = "okay";
++};
+
-+ ehci1: usb@01c1c000 {
-+ status = "okay";
-+ };
++&ehci1 {
++ status = "okay";
++};
+
-+ ohci1: usb@01c1c400 {
-+ status = "okay";
-+ };
++&gmac {
++ pinctrl-names = "default";
++ pinctrl-0 = <&gmac_pins_rgmii_a>;
++ phy = <&phy1>;
++ phy-mode = "rgmii";
++ phy-supply = <&reg_gmac_3v3>;
++ status = "okay";
+
-+ pinctrl@01c20800 {
-+ mmc0_cd_pin_bananapi: mmc0_cd_pin@0 {
-+ allwinner,pins = "PH10";
-+ allwinner,function = "gpio_in";
-+ allwinner,drive = <0>;
-+ allwinner,pull = <1>;
-+ };
-+
-+ gmac_power_pin_bananapi: gmac_power_pin@0 {
-+ allwinner,pins = "PH23";
-+ allwinner,function = "gpio_out";
-+ allwinner,drive = <0>;
-+ allwinner,pull = <0>;
-+ };
-+
-+ led_pins_bananapi: led_pins@0 {
-+ allwinner,pins = "PH24";
-+ allwinner,function = "gpio_out";
-+ allwinner,drive = <0>;
-+ allwinner,pull = <0>;
-+ };
-+
-+ ahci_pwr_pin_a: ahci_pwr_pin@0 {
-+ allwinner,pins = "PB3";
-+ allwinner,function = "gpio_out";
-+ allwinner,drive = <0>;
-+ allwinner,pull = <0>;
-+ };
-+
-+ };
++ phy1: ethernet-phy@1 {
++ reg = <1>;
++ };
++};
+
++&i2c0 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&i2c0_pins_a>;
++ status = "okay";
+
-+ uart0: serial@01c28000 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&uart0_pins_a>;
-+ status = "okay";
-+ };
++ axp209: pmic@34 {
++ compatible = "x-powers,axp209";
++ reg = <0x34>;
++ interrupt-parent = <&nmi_intc>;
++ interrupts = <0 IRQ_TYPE_LEVEL_LOW>;
+
-+ uart3: serial@01c28c00 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&uart3_pins_b>;
-+ status = "okay";
-+ };
++ interrupt-controller;
++ #interrupt-cells = <1>;
++ };
++};
+
-+ uart7: serial@01c29c00 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&uart7_pins_a>;
-+ status = "okay";
-+ };
++&i2c2 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&i2c2_pins_a>;
++ status = "okay";
++};
+
-+ i2c0: i2c@01c2ac00 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&i2c0_pins_a>;
-+ status = "okay";
++&ir0 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&ir0_rx_pins_a>;
++ status = "okay";
++};
+
-+ axp209: pmic@34 {
-+ compatible = "x-powers,axp209";
-+ reg = <0x34>;
-+ interrupt-parent = <&nmi_intc>;
-+ interrupts = <0 8>;
++&mmc0 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&mmc0_pins_a>, <&mmc0_cd_pin_bananapi>;
++ vmmc-supply = <&reg_vcc3v3>;
++ bus-width = <4>;
++ cd-gpios = <&pio 7 10 GPIO_ACTIVE_HIGH>; /* PH10 */
++ cd-inverted;
++ status = "okay";
++};
+
-+ interrupt-controller;
-+ #interrupt-cells = <1>;
-+ };
-+ };
++&ohci0 {
++ status = "okay";
++};
+
-+ i2c2: i2c@01c2b400 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&i2c2_pins_a>;
-+ status = "okay";
-+ };
++&ohci1 {
++ status = "okay";
++};
+
-+ gmac: ethernet@01c50000 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&gmac_pins_rgmii_a>;
-+ phy = <&phy1>;
-+ phy-mode = "rgmii";
-+ phy-supply = <&reg_gmac_3v3>;
-+ status = "okay";
-+
-+ phy1: ethernet-phy@1 {
-+ reg = <1>;
-+ };
-+ };
++&pio {
++ mmc0_cd_pin_bananapi: mmc0_cd_pin@0 {
++ allwinner,pins = "PH10";
++ allwinner,function = "gpio_in";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_PULL_UP>;
+ };
+
-+ leds {
-+ compatible = "gpio-leds";
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&led_pins_bananapi>;
-+
-+ green {
-+ label = "bananapi:green:usr";
-+ gpios = <&pio 7 24 0>;
-+ };
++ gmac_power_pin_bananapi: gmac_power_pin@0 {
++ allwinner,pins = "PH23";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
+ };
+
-+ reg_usb1_vbus: usb1-vbus {
-+ status = "okay";
++ led_pins_bananapi: led_pins@0 {
++ allwinner,pins = "PH24";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
+ };
+
-+ reg_usb2_vbus: usb2-vbus {
-+ status = "okay";
-+ };
++ ir0_tx_pins_a: ir0@1 {
++ allwinner,pins = "PB3";
++ allwinner,function = "ir0";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_PULL_UP>;
++ };
+
-+ reg_gmac_3v3: gmac-3v3 {
-+ compatible = "regulator-fixed";
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&gmac_power_pin_bananapi>;
-+ regulator-name = "gmac-3v3";
-+ regulator-min-microvolt = <3300000>;
-+ regulator-max-microvolt = <3300000>;
-+ startup-delay-us = <100000>;
-+ enable-active-high;
-+ gpio = <&pio 7 23 0>;
-+ };
++};
+
-+ reg_ahci_5v: ahci-5v {
-+ compatible = "regulator-fixed";
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&ahci_pwr_pin_a>;
-+ regulator-name = "ahci-5v";
-+ regulator-min-microvolt = <5000000>;
-+ regulator-max-microvolt = <5000000>;
-+ enable-active-high;
-+ gpio = <&pio 1 3 0>;
-+ status = "okay";
-+ };
++&reg_usb1_vbus {
++ status = "okay";
+};
-diff -ruN old/configs/Lamobo_R1_defconfig new/configs/Lamobo_R1_defconfig
---- old/configs/Lamobo_R1_defconfig 1970-01-01 01:00:00.000000000 +0100
-+++ new/configs/Lamobo_R1_defconfig 2015-07-31 23:02:06.000000000 +0200
-@@ -0,0 +1,19 @@
-+CONFIG_SPL=y
-+CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI,SATAPWR=SUNXI_GPB(3)"
-+CONFIG_DEFAULT_DEVICE_TREE="sun7i-a20-lamobo-r1"
-+CONFIG_GMAC_TX_DELAY=4
++
++&reg_usb2_vbus {
++ status = "okay";
++};
++
++&spi0 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&spi0_pins_a>,
++ <&spi0_cs0_pins_a>,
++ <&spi0_cs1_pins_a>;
++ status = "okay";
++};
++
++&uart0 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&uart0_pins_a>;
++ status = "okay";
++};
++
++&uart3 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&uart3_pins_b>;
++ status = "okay";
++};
++
++&uart7 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&uart7_pins_a>;
++ status = "okay";
++};
++
++&usbphy {
++ usb1_vbus-supply = <&reg_usb1_vbus>;
++ usb2_vbus-supply = <&reg_usb2_vbus>;
++ status = "okay";
++};
+diff --git a/board/sunxi/MAINTAINERS b/board/sunxi/MAINTAINERS
+index 7a42055..abf2c1c 100644
+--- a/board/sunxi/MAINTAINERS
++++ b/board/sunxi/MAINTAINERS
+@@ -30,6 +30,7 @@ F: include/configs/sun7i.h
+ F: configs/A20-OLinuXino_MICRO_defconfig
+ F: configs/Bananapi_defconfig
+ F: configs/Bananapro_defconfig
++F: configs/Lamobo_R1_defconfig
+ F: configs/i12-tvbox_defconfig
+ F: configs/Linksprite_pcDuino3_defconfig
+ F: configs/Linksprite_pcDuino3_fdt_defconfig
+diff --git a/configs/Lamobo_R1_defconfig b/configs/Lamobo_R1_defconfig
+new file mode 100644
+index 0000000..bf665e7
+--- /dev/null
++++ b/configs/Lamobo_R1_defconfig
+@@ -0,0 +1,17 @@
+CONFIG_ARM=y
+CONFIG_ARCH_SUNXI=y
+CONFIG_MACH_SUN7I=y
+CONFIG_DRAM_CLK=432
-+CONFIG_DRAM_ZQ=127
-+CONFIG_DRAM_EMR1=4
++CONFIG_GMAC_TX_DELAY=4
++CONFIG_DEFAULT_DEVICE_TREE="sun7i-a20-lamobo-r1"
++CONFIG_SPL=y
++CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI"
+CONFIG_ETH_DESIGNWARE=y
-+CONFIG_NETDEVICES=y
-+CONFIG_NET=y
+# CONFIG_CMD_IMLS is not set
+# CONFIG_CMD_FLASH is not set
+# CONFIG_CMD_FPGA is not set
+CONFIG_DM_SERIAL=y
+CONFIG_USB=y
+CONFIG_DM_USB=y
++CONFIG_NETDEVICES=y
++CONFIG_NET=y