aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2013-11-13 10:49:22 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2013-11-13 10:49:22 +0000
commit411e18ee5c200a8bb9aa44b817b1238e78815107 (patch)
tree0b360879b12dbb703bde1a1998fa53be17862393 /package/boot/uboot-sunxi
parent97a977aa84e9b7f36ecf43a89d17bd6569e4db57 (diff)
downloadmaster-187ad058-411e18ee5c200a8bb9aa44b817b1238e78815107.tar.gz
master-187ad058-411e18ee5c200a8bb9aa44b817b1238e78815107.tar.bz2
master-187ad058-411e18ee5c200a8bb9aa44b817b1238e78815107.zip
[package]: uboot-sunxi: add U-boot builds for a couple sunxi boards
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38785 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/Makefile107
1 files changed, 107 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
new file mode 100644
index 0000000000..da729dd969
--- /dev/null
+++ b/package/boot/uboot-sunxi/Makefile
@@ -0,0 +1,107 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=2013.10-rc2-sunxi
+PKG_RELEASE:=1
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://github.com/linux-sunxi/u-boot-sunxi
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=8a4621c488f33089d831168bfa5bae210a5684c8
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define uboot/Default
+ TITLE:=
+ CONFIG:=
+ IMAGE:=
+endef
+
+define uboot/A13-OLinuXino
+ TITLE:=U-Boot 2013.10-rc2 for the A13 Olinuxino
+endef
+
+define uboot/Hackberry
+ TITLE:=U-Boot 2013.10-rc2 for the Hackbeery
+endef
+
+define uboot/Cubieboard
+ TITLE:=U-Boot 2013.10-rc2 for Cubieboard
+endef
+
+define uboot/Cubieboard2
+ TITLE:=U-Boot 2013.10-rc2 for Cubieboard2
+endef
+
+define uboot/A20-OLinuXino_MICRO
+ TITLE:=U-Boot 2013.10-rc2 for A20 Olinuxino
+endef
+
+UBOOTS:=A13-OLinuXino Cubieboard Cubieboard2 A20-OLinuXino_MICRO Hackberry
+
+define Package/uboot/template
+define Package/uboot-sunxi-$(1)
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ DEPENDS:=@TARGET_sunxi
+ TITLE:=$(2)
+ URL:=http://www.denx.de/wiki/U-Boot
+ VARIANT:=$(1)
+ MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+endef
+endef
+
+define BuildUBootPackage
+ $(eval $(uboot/Default))
+ $(eval $(uboot/$(1)))
+ $(call Package/uboot/template,$(1),$(TITLE))
+endef
+
+ifdef BUILD_VARIANT
+$(eval $(call uboot/$(BUILD_VARIANT)))
+UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
+endif
+
+define Build/Configure
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(UBOOT_CONFIG)_config
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CROSS_COMPILE=$(TARGET_CROSS)
+endef
+
+define Package/uboot/install/default
+ $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
+ $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.bin
+ $(CP) $(PKG_BUILD_DIR)/spl/sunxi-spl.bin \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-sunxi-spl.bin
+ $(CP) $(PKG_BUILD_DIR)/u-boot-sunxi-with-spl.bin \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-sunxi-with-spl.bin
+endef
+
+define Package/uboot/install/template
+define Package/uboot-sunxi-$(1)/install
+ $(call Package/uboot/install/default,$(2))
+endef
+endef
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call Package/uboot/install/template,$(u),$(u))) \
+)
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call BuildUBootPackage,$(u))) \
+ $(eval $(call BuildPackage,uboot-sunxi-$(u))) \
+)