aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-socfpga/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-05-10 22:52:00 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:35:42 +0200
commit9ccd1da444ff320abf069322b6063d7d041cdd20 (patch)
tree6e4bf314ba8e2ae7ffd68f166a46977aad676ec8 /package/boot/uboot-socfpga/Makefile
parentc3d9ae93fd2cfb51ae3e843487edad81545afca4 (diff)
downloadmaster-187ad058-9ccd1da444ff320abf069322b6063d7d041cdd20.tar.gz
master-187ad058-9ccd1da444ff320abf069322b6063d7d041cdd20.tar.bz2
master-187ad058-9ccd1da444ff320abf069322b6063d7d041cdd20.zip
target: socfpga: Add Altera SoCFPGA support
This patch adds support for the Altera SoCFPGA target. Both generic target and Terasic SoCkit boards are supported. Signed-off-by: Marek Vasut <marex@denx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49367 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-socfpga/Makefile')
-rw-r--r--package/boot/uboot-socfpga/Makefile97
1 files changed, 97 insertions, 0 deletions
diff --git a/package/boot/uboot-socfpga/Makefile b/package/boot/uboot-socfpga/Makefile
new file mode 100644
index 0000000000..42fcb43af6
--- /dev/null
+++ b/package/boot/uboot-socfpga/Makefile
@@ -0,0 +1,97 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=2016.03
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=973c1d896be751321cc3aafa564f64b2
+
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define uboot/Default
+ TITLE:=
+ CONFIG:=
+ IMAGE:=
+endef
+
+define uboot/socfpga_cyclone5_sockit
+ TITLE := U-Boot for Terasic SoCkit board
+ CONFIG := socfpga_sockit
+ IMAGE := u-boot-with-spl.sfp
+endef
+
+UBOOTS := \
+ socfpga_cyclone5_sockit
+
+define Package/uboot/template
+define Package/uboot-socfpga-$(1)
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ DEPENDS:=@TARGET_socfpga
+ TITLE:=$(2)
+ URL:=http://www.denx.de/wiki/U-Boot
+ VARIANT:=$(1)
+ MAINTAINER:=Marek Vasut <marex@denx.de>
+endef
+endef
+
+define BuildUBootPackage
+ $(eval $(uboot/Default))
+ $(eval $(uboot/$(1)))
+ $(call Package/uboot/template,$(1),$(TITLE))
+endef
+
+ifdef BUILD_VARIANT
+$(eval $(call uboot/$(BUILD_VARIANT)))
+UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
+endif
+
+define Build/Configure
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+endef
+
+define Build/Compile
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS) $(IMAGE)
+endef
+
+define Package/uboot/install/default
+ $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
+ $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.bin
+ $(CP) $(PKG_BUILD_DIR)/spl/u-boot-spl.bin \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-spl.bin
+ $(CP) $(PKG_BUILD_DIR)/u-boot-with-spl.sfp \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-with-spl.sfp
+endef
+
+define Package/uboot/install/template
+define Package/uboot-socfpga-$(1)/install
+ $(call Package/uboot/install/default,$(2))
+endef
+endef
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call Package/uboot/install/template,$(u),$(u))) \
+)
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call BuildUBootPackage,$(u))) \
+ $(eval $(call BuildPackage,uboot-socfpga-$(u))) \
+)