aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-04-12 21:21:35 +0000
committerJohn Crispin <blogic@openwrt.org>2014-04-12 21:21:35 +0000
commit2feab056c29754e5af4a45ba0332165cdb240824 (patch)
tree3d4f88c555b437fa39d0c89b2d7637f7d2090ac9 /package/boot/uboot-lantiq
parent0fe935c56bf505cfec8383d413c02a552db83ccc (diff)
downloadmaster-187ad058-2feab056c29754e5af4a45ba0332165cdb240824.tar.gz
master-187ad058-2feab056c29754e5af4a45ba0332165cdb240824.tar.bz2
master-187ad058-2feab056c29754e5af4a45ba0332165cdb240824.zip
uboot-lantiq: reuse/copy VR9 GPHY firmware blobs from target/linux/lantiq
Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40487 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-lantiq')
-rw-r--r--package/boot/uboot-lantiq/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index c0a8b6e386..078c79c054 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -21,6 +21,8 @@ PKG_TARGETS:=bin
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+FIRMWARE_LANTIQ_SOURCE:=$(TOPDIR)/target/linux/lantiq/files/firmware/lantiq
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default
@@ -202,6 +204,19 @@ define BuildUBootPackage
$(call Package/uboot/template,$(1),$(TITLE))
endef
+define CopyVR9Firmware
+ $(CP) $(FIRMWARE_LANTIQ_SOURCE)/vr9_phy$(1)_a$(2)x.bin \
+ $(PKG_BUILD_DIR)/arch/mips/cpu/mips32/vrx200/fw_phy$(1)_a$(2)x.blob
+endef
+
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ $(call CopyVR9Firmware,11g,1)
+ $(call CopyVR9Firmware,11g,2)
+ $(call CopyVR9Firmware,22f,1)
+ $(call CopyVR9Firmware,22f,2)
+endef
+
define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) $(BUILD_VARIANT)_config
endef