aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-08-29 23:06:31 +0000
committerLuka Perkov <luka@openwrt.org>2013-08-29 23:06:31 +0000
commit766d4089cde790f2c36c5aa17e9732af0108e285 (patch)
treebef2c41bd01fd1eeb83bc7a96f80b01364721ac1 /package/boot/uboot-imx6
parent8901997bbca7da712299a4f642727e4d3006f824 (diff)
downloadmaster-187ad058-766d4089cde790f2c36c5aa17e9732af0108e285.tar.gz
master-187ad058-766d4089cde790f2c36c5aa17e9732af0108e285.tar.bz2
master-187ad058-766d4089cde790f2c36c5aa17e9732af0108e285.zip
[package] uboot-imx6: update to v2013.07
Update includes upstream support for Wandboard Quad too. Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37858 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-imx6')
-rw-r--r--package/boot/uboot-imx6/Makefile11
-rw-r--r--package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch2
-rw-r--r--package/boot/uboot-imx6/patches/110-wandboard-owrt-env.patch (renamed from package/boot/uboot-imx6/patches/110-wandboard-owrt-env-patch)17
3 files changed, 19 insertions, 11 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 16465c78e2..21c7b09718 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=u-boot
-PKG_VERSION:=2013.04
+PKG_VERSION:=2013.07
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=21bf962d69938ed4ed783b792b2b074e
+PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
include $(INCLUDE_DIR)/package.mk
@@ -32,9 +32,14 @@ define uboot/wandboard_dl
TITLE:=U-Boot for the Wandboard Dual Lite
endef
+define uboot/wandboard_quad
+ TITLE:=U-Boot for the Wandboard Quad
+endef
+
UBOOTS := \
wandboard_solo \
- wandboard_dl
+ wandboard_dl \
+ wandboard_quad
define Package/uboot/template
define Package/uboot-imx6-$(1)
diff --git a/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch b/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
index f4fb2c683e..f847c5a790 100644
--- a/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
+++ b/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
@@ -1,6 +1,6 @@
--- a/include/configs/wandboard.h
+++ b/include/configs/wandboard.h
-@@ -206,4 +206,7 @@
+@@ -242,4 +242,7 @@
#define CONFIG_CMD_CACHE
#endif
diff --git a/package/boot/uboot-imx6/patches/110-wandboard-owrt-env-patch b/package/boot/uboot-imx6/patches/110-wandboard-owrt-env.patch
index e14f56394f..6869c85d0f 100644
--- a/package/boot/uboot-imx6/patches/110-wandboard-owrt-env-patch
+++ b/package/boot/uboot-imx6/patches/110-wandboard-owrt-env.patch
@@ -1,19 +1,22 @@
--- a/include/configs/wandboard.h
+++ b/include/configs/wandboard.h
-@@ -47,7 +47,7 @@
-
- #undef CONFIG_CMD_IMLS
+@@ -51,7 +51,7 @@
+ #define CONFIG_CMD_BMODE
+ #define CONFIG_CMD_SETEXPR
-#define CONFIG_BOOTDELAY 5
+#define CONFIG_BOOTDELAY 3
#define CONFIG_SYS_MEMTEST_START 0x10000000
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
-@@ -83,13 +83,15 @@
+@@ -103,15 +103,18 @@
#if defined(CONFIG_MX6DL)
#define CONFIG_DEFAULT_FDT_FILE "imx6dl-wandboard.dtb"
+#define CONFIG_OWRT_NAME "openwrt-imx6dl-wandboard-uImage.itb"
+ #elif defined(CONFIG_MX6Q)
+ #define CONFIG_DEFAULT_FDT_FILE "imx6q-wandboard.dtb"
++#define CONFIG_OWRT_NAME "openwrt-imx6q-wandboard-uImage.itb"
#elif defined(CONFIG_MX6S)
#define CONFIG_DEFAULT_FDT_FILE "imx6s-wandboard.dtb"
+#define CONFIG_OWRT_NAME "openwrt-imx6s-wandboard-uImage.itb"
@@ -26,7 +29,7 @@
"console=ttymxc0\0" \
"fdt_high=0xffffffff\0" \
"initrd_high=0xffffffff\0" \
-@@ -103,11 +105,11 @@
+@@ -139,11 +142,11 @@
"mmcargs=setenv bootargs console=${console},${baudrate} " \
"root=${mmcroot}\0" \
"loadbootscript=" \
@@ -41,7 +44,7 @@
"mmcboot=echo Booting from mmc ...; " \
"run mmcargs; " \
"if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
-@@ -122,30 +124,6 @@
+@@ -158,30 +161,6 @@
"fi; " \
"else " \
"bootm; " \
@@ -72,7 +75,7 @@
"fi;\0"
#define CONFIG_BOOTCOMMAND \
-@@ -155,10 +133,10 @@
+@@ -191,10 +170,10 @@
"else " \
"if run loaduimage; then " \
"run mmcboot; " \