aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:19 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:19 +0000
commitc78da29d8ef6752bfb972cd6f8d35fa5fe2a0efc (patch)
tree7a916d23836c489efc29ef437b650965667a0b0c /package/boot/uboot-envtools/Makefile
parent8cbc083fde18b844333536bfda31ded18091ffe1 (diff)
downloadmaster-187ad058-c78da29d8ef6752bfb972cd6f8d35fa5fe2a0efc.tar.gz
master-187ad058-c78da29d8ef6752bfb972cd6f8d35fa5fe2a0efc.tar.bz2
master-187ad058-c78da29d8ef6752bfb972cd6f8d35fa5fe2a0efc.zip
uboot-envtools: add support for environment in ubi volume
On UBI enabled devices, U-Boot might store it's environment on UBI volume(s). Support this in uboot-envtools, so fw_setenv and fw_printenv can work on these platforms. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40929 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 9f167edbfb..dad971a4e4 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -21,6 +21,8 @@ PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=+fstools
+
include $(INCLUDE_DIR)/package.mk
define Package/uboot-envtools
@@ -34,15 +36,22 @@ define Package/uboot-envtools/description
This package includes tools to read and modify U-Boot bootloader environment.
endef
+define Package/uboot-envtools/config
+ source "$(SOURCE)/Config.in"
+endef
+
define Build/Configure
touch $(PKG_BUILD_DIR)/include/config.mk
touch $(PKG_BUILD_DIR)/include/config.h
endef
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE="$(TARGET_CROSS)" \
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+ UBI="$(CONFIG_UBOOT_ENVTOOLS_UBI)" \
env
endef