aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-ar71xx/patches/021-darwin_compat.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-10-16 13:44:25 +0000
committerJohn Crispin <blogic@openwrt.org>2012-10-16 13:44:25 +0000
commita7fb4200cccec4f1e521b803044714901f7bc410 (patch)
tree5937de88cb9dca7bfebc4dc3dce3cf904bf65357 /package/boot/uboot-ar71xx/patches/021-darwin_compat.patch
parente910e78dba966a90ce42a39c7496c279b9d915cc (diff)
downloadmaster-187ad058-a7fb4200cccec4f1e521b803044714901f7bc410.tar.gz
master-187ad058-a7fb4200cccec4f1e521b803044714901f7bc410.tar.bz2
master-187ad058-a7fb4200cccec4f1e521b803044714901f7bc410.zip
[boot] move boot related packages to their own folder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33781 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-ar71xx/patches/021-darwin_compat.patch')
-rw-r--r--package/boot/uboot-ar71xx/patches/021-darwin_compat.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/boot/uboot-ar71xx/patches/021-darwin_compat.patch b/package/boot/uboot-ar71xx/patches/021-darwin_compat.patch
new file mode 100644
index 0000000000..dde83d4905
--- /dev/null
+++ b/package/boot/uboot-ar71xx/patches/021-darwin_compat.patch
@@ -0,0 +1,23 @@
+--- a/config.mk
++++ b/config.mk
+@@ -64,9 +64,17 @@ HOSTSTRIP = strip
+ #
+
+ ifeq ($(HOSTOS),darwin)
+-HOSTCC = cc
+-HOSTCFLAGS += -traditional-cpp
+-HOSTLDFLAGS += -multiply_defined suppress
++#get the major and minor product version (e.g. '10' and '6' for Snow Leopard)
++DARWIN_MAJOR_VERSION = $(shell sw_vers -productVersion | cut -f 1 -d '.')
++DARWIN_MINOR_VERSION = $(shell sw_vers -productVersion | cut -f 2 -d '.')
++
++before-snow-leopard = $(shell if [ $(DARWIN_MAJOR_VERSION) -le 10 -a \
++ $(DARWIN_MINOR_VERSION) -le 5 ] ; then echo "$(1)"; else echo "$(2)"; fi ;)
++
++# Snow Leopards build environment has no longer restrictions as described above
++HOSTCC = $(call before-snow-leopard, "cc", "gcc")
++HOSTCFLAGS += $(call before-snow-leopard, "-traditional-cpp")
++HOSTLDFLAGS += $(call before-snow-leopard, "-multiply_defined suppress")
+ else
+ HOSTCC = gcc
+ endif