aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/fconfig
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-10-16 13:44:25 +0000
committerJohn Crispin <blogic@openwrt.org>2012-10-16 13:44:25 +0000
commita7fb4200cccec4f1e521b803044714901f7bc410 (patch)
tree5937de88cb9dca7bfebc4dc3dce3cf904bf65357 /package/boot/fconfig
parente910e78dba966a90ce42a39c7496c279b9d915cc (diff)
downloadmaster-187ad058-a7fb4200cccec4f1e521b803044714901f7bc410.tar.gz
master-187ad058-a7fb4200cccec4f1e521b803044714901f7bc410.tar.bz2
master-187ad058-a7fb4200cccec4f1e521b803044714901f7bc410.zip
[boot] move boot related packages to their own folder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33781 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/fconfig')
-rw-r--r--package/boot/fconfig/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/boot/fconfig/Makefile b/package/boot/fconfig/Makefile
new file mode 100644
index 0000000000..14bbec57b8
--- /dev/null
+++ b/package/boot/fconfig/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fconfig
+PKG_VERSION:=20080329
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://andrzejekiert.ovh.org/software/fconfig/
+PKG_MD5SUM:=dac355e9f2a0f48c414c52e2034b6346
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fconfig
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=RedBoot configuration editor
+ URL:=http://andrzejekiert.ovh.org/software.html.en
+endef
+
+define Package/fconfig/description
+ displays and (if writable) also edits the RedBoot configuration.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(call Build/Compile/Default)
+endef
+
+define Package/fconfig/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,fconfig))