aboutsummaryrefslogtreecommitdiffstats
path: root/package/bcm43xx-mac80211
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-22 04:55:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-22 04:55:38 +0000
commit74d7a9b4a58bba9fa29d85a1ad649c4428951856 (patch)
treee6718bca662c9141a1d13426baa3e1a8a7ce7080 /package/bcm43xx-mac80211
parent850a0acec6390a433dfa182b665a9b8c9606b55e (diff)
downloadmaster-187ad058-74d7a9b4a58bba9fa29d85a1ad649c4428951856.tar.gz
master-187ad058-74d7a9b4a58bba9fa29d85a1ad649c4428951856.tar.bz2
master-187ad058-74d7a9b4a58bba9fa29d85a1ad649c4428951856.zip
[7701] for bcm43xx-mac80211 as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7703 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/bcm43xx-mac80211')
-rw-r--r--package/bcm43xx-mac80211/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/bcm43xx-mac80211/Makefile b/package/bcm43xx-mac80211/Makefile
index d423620430..4725cd7e18 100644
--- a/package/bcm43xx-mac80211/Makefile
+++ b/package/bcm43xx-mac80211/Makefile
@@ -32,8 +32,10 @@ define KernelPackage/bcm43xx-mac80211
VERSION:=$(PKG_RELEASE)+$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
DEPENDS:=@LINUX_2_6 +kmod-mac80211
SUBMENU:=Wireless Drivers
+ ifneq ($(KERNEL_PATCHVER),2.6.21)
# AUTOLOAD:=$(call AutoLoad,30,bcm43xx-mac80211)
- FILES:=$(PKG_BUILD_DIR)/bcm43xx-mac80211.$(LINUX_KMOD_SUFFIX)
+ FILES:=$(PKG_BUILD_DIR)/bcm43xx-mac80211.$(LINUX_KMOD_SUFFIX)
+ endif
endef
define Build/Prepare
@@ -41,13 +43,15 @@ define Build/Prepare
$(CP) ./src/bcm43xx/* $(PKG_BUILD_DIR)/
endef
-define Build/Compile
+ifneq ($(KERNEL_PATCHVER),2.6.21)
+ define Build/Compile
$(MAKE) $(MAKE_CONFIGS) -C "$(LINUX_DIR)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
ARCH="$(LINUX_KARCH)" \
EXTRA_CFLAGS="$(BUILDFLAGS)" \
SUBDIRS="$(PKG_BUILD_DIR)" \
modules
-endef
+ endef
+endif
$(eval $(call KernelPackage,bcm43xx-mac80211))