aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-02-01 10:47:17 +0000
committerMike Baker <mbm@openwrt.org>2006-02-01 10:47:17 +0000
commita5d9d02c3a7a26f91ea99c83598dbca32136872e (patch)
treed61e3c02be52de8e16e9531c0ddb8f3d2c28f444 /package/base-files
parentac7b6ef636e75dea84e4dd9ca1b9be433398b754 (diff)
downloadmaster-187ad058-a5d9d02c3a7a26f91ea99c83598dbca32136872e.tar.gz
master-187ad058-a5d9d02c3a7a26f91ea99c83598dbca32136872e.tar.bz2
master-187ad058-a5d9d02c3a7a26f91ea99c83598dbca32136872e.zip
move sysfs to mount_root
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3107 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile1
-rwxr-xr-xpackage/base-files/default/etc/preinit5
-rwxr-xr-xpackage/base-files/default/sbin/mount_root1
3 files changed, 2 insertions, 5 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 958262761e..e4753d045c 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -55,6 +55,7 @@ $(IPKG_BASE):
cp -a ./default/* $(IDIR_BASE)
$(SED) 's,$$R,r$(REV),g' $(IDIR_BASE)/etc/banner
$(SED) 's,$$S,$(BOARD)-$(KERNEL),g' $(IDIR_BASE)/etc/ipkg.conf
+ mkdir -p $(IDIR_BASE)/sys
mkdir -p $(IDIR_BASE)/jffs
mkdir -p $(IDIR_BASE)/dev
mkdir -p $(IDIR_BASE)/proc
diff --git a/package/base-files/default/etc/preinit b/package/base-files/default/etc/preinit
index f82823ec9c..ac9039ca71 100755
--- a/package/base-files/default/etc/preinit
+++ b/package/base-files/default/etc/preinit
@@ -21,9 +21,4 @@ mount_root ${FAILSAFE:+failsafe}
{ mount|grep "on / type jffs2" 1>&-; } || firstboot
}
-grep sysfs /proc/filesystems >&- 2>&- && {
- mkdir -p /sys
- mount -t sysfs none /sys
-}
-
exec /sbin/init
diff --git a/package/base-files/default/sbin/mount_root b/package/base-files/default/sbin/mount_root
index bd9b815e12..427ff0444f 100755
--- a/package/base-files/default/sbin/mount_root
+++ b/package/base-files/default/sbin/mount_root
@@ -37,3 +37,4 @@ fi
mount none /tmp -t tmpfs -o nosuid,nodev,mode=1777,size=50%
mkdir -p /dev/pts
mount none /dev/pts -t devpts
+grep sysfs /proc/filesystems >&- && mount -t sysfs none /sys