aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2006-01-04 08:37:19 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2006-01-04 08:37:19 +0000
commit13b12c06c87998480e2642cb762693694f0c3b0f (patch)
tree2005252ef3db9de34d1b0b10656fae07bf82d55e /package/base-files
parent9feda69af9dd6682ef0f92a4f63c223f1174e18b (diff)
downloadmaster-187ad058-13b12c06c87998480e2642cb762693694f0c3b0f.tar.gz
master-187ad058-13b12c06c87998480e2642cb762693694f0c3b0f.tar.bz2
master-187ad058-13b12c06c87998480e2642cb762693694f0c3b0f.zip
patch for spec file of gcc 3.4.4, so that libgss library is not
automatically linked into every binary. explicitely link it into needed packages (kismet, nmap, samba) and add dependencies. idea and patch from sven-ola, thx. Saves 16 kb in the default squashfs images. git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2817 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile12
-rw-r--r--package/base-files/ipkg/uclibc.control2
2 files changed, 11 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 8b74ee0d9c..7601de2ad0 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -29,7 +29,15 @@ LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
IDIR_LIBGCC:=$(PKG_BUILD_DIR)/libgcc
IPKG_LIBGCC:=$(PACKAGE_DIR)/libgcc_$(LIBGCC_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PACKAGES:=$(IPKG_BASE) $(IPKG_UCLIBC) $(IPKG_LIBGCC)
+PACKAGES:=$(IPKG_BASE) $(IPKG_UCLIBC)
+PACKAGES_INSTALL:=$(IPKG_BASE) $(IPKG_UCLIBC)
+
+ifeq ($(BR2_PACKAGE_LIBGCC),y)
+PACKAGES_INSTALL+=$(IPKG_LIBGCC)
+endif
+ifeq ($(BR2_PACKAGE_LIBGCC),m)
+PACKAGES+=$(IPKG_LIBGCC)
+endif
$(PKG_BUILD_DIR)/.prepared:
mkdir -p $(PKG_BUILD_DIR) $(PACKAGE_DIR)
@@ -88,4 +96,4 @@ prepare:
compile-targets: $(PACKAGES)
install-targets: compile
mkdir -p $(TARGET_DIR)
- $(IPKG) install $(PACKAGES)
+ $(IPKG) install $(PACKAGES_INSTALL)
diff --git a/package/base-files/ipkg/uclibc.control b/package/base-files/ipkg/uclibc.control
index d07ed90681..1cdfe157cb 100644
--- a/package/base-files/ipkg/uclibc.control
+++ b/package/base-files/ipkg/uclibc.control
@@ -1,5 +1,5 @@
Package: uclibc
Priority: optional
Section: net
-Depends: base-files, libgcc
+Depends: base-files
Description: Standard C library for embedded Linux systems