aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-14 17:44:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-14 17:44:42 +0000
commit3e44099b61d1c1d0e420cd5e079f9092a03d3ec3 (patch)
tree660c3296656a54d334b05670774930e992c71ec0 /package/base-files/Makefile
parent6bb46d75aaac5a9776011c3569527249fe06c386 (diff)
downloadmaster-187ad058-3e44099b61d1c1d0e420cd5e079f9092a03d3ec3.tar.gz
master-187ad058-3e44099b61d1c1d0e420cd5e079f9092a03d3ec3.tar.bz2
master-187ad058-3e44099b61d1c1d0e420cd5e079f9092a03d3ec3.zip
base-files: add macaddr_canonicalize helper function
In commit r38690, the MAC address canonicalization has been converted to use 'tr' instead of 'printf'. This only works if with MAC addresses which uses the 'xx:xx:xx:xx:xx:xx' format. However on some boards, the MAC addresses are stored in different format in the mtd partition. Some vendors are using hyphens or dots as separators instead of colons. Also the leading zeroes may be missing from the individual octets or those are replaced with spaces. Add a new function which can be used to convert these into the 'xx:xx:xx:xx:xx:xx' format. Also update the 'mtd_get_mac_ascii' function to use the new helper. The helper function is based on this code: http://isquared.nl/blog/2010/08/11/Bash-function-to-canonicalize-MAC-addresses/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38803 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 31c6e984bc..0160e41f88 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=148
+PKG_RELEASE:=149
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host