aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2011-02-18 10:37:26 +0000
committerHamish Guthrie <hcg@openwrt.org>2011-02-18 10:37:26 +0000
commit3156ceea1d04ff48a6178aa5c6a8b2375716f564 (patch)
tree7ac466ec60d38a7e68ec50cd8757a841afd0a67b /package/base-files/Makefile
parentec1ab875da455fa26ce2fe2b0e681f3ddc9d3c7f (diff)
downloadmaster-187ad058-3156ceea1d04ff48a6178aa5c6a8b2375716f564.tar.gz
master-187ad058-3156ceea1d04ff48a6178aa5c6a8b2375716f564.tar.bz2
master-187ad058-3156ceea1d04ff48a6178aa5c6a8b2375716f564.zip
[package] base-files: Add /etc/nsswitch.conf to targets running glibc/eglibc, otherwise name resolution fails
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25568 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 3ccd2c7f4b..4abbdf7ac4 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -416,6 +416,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
use_nsswitch=$(if $(CONFIG_USE_GLIBC)$(CONFIG_EGLIBC_OPTION_EGLIBC_NSSWITCH),libnss_dns libnss_files)
define Package/glibc/install
+ $(CP) ./glibc-files/* $(1)/
$(INSTALL_DIR) $(1)/lib
$(CP) \
$(TOOLCHAIN_DIR)/lib/ld*.so.* \