aboutsummaryrefslogtreecommitdiffstats
path: root/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-11 12:48:09 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-11 12:48:09 +0000
commitba0502d5a2848ef9e71b4b75f3d53c1acae68581 (patch)
treeb74eda8e7a86a21a9a9626b6416ecca6c2c9101c /package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
parent669aac5d08a1b45d680e288f3611eab8aa95d7ad (diff)
downloadmaster-187ad058-ba0502d5a2848ef9e71b4b75f3d53c1acae68581.tar.gz
master-187ad058-ba0502d5a2848ef9e71b4b75f3d53c1acae68581.tar.bz2
master-187ad058-ba0502d5a2848ef9e71b4b75f3d53c1acae68581.zip
Update to new upstream release (v1.0.9),
Split makefile patch into multiple patches, Add no-gtk fix from whiterussian. git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1402 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch')
-rw-r--r--package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch b/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
new file mode 100644
index 0000000000..8d8932875c
--- /dev/null
+++ b/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
@@ -0,0 +1,33 @@
+diff -ruN asterisk-1.0.7-old/channels/h323/Makefile asterisk-1.0.7-new/channels/h323/Makefile
+--- asterisk-1.0.7-old/channels/h323/Makefile 2004-11-15 03:35:35.000000000 +0100
++++ asterisk-1.0.7-new/channels/h323/Makefile 2005-03-19 17:38:06.000000000 +0100
+@@ -22,9 +22,11 @@
+ OSARCH=$(shell uname -s)
+ ifneq (${OSARCH},FreeBSD)
+ ifneq (${OSARCH},NetBSD)
++ifneq ($(PROC),mipsel)
+ CFLAGS += -march=$(shell uname -m)
+ endif
+ endif
++endif
+ CFLAGS += -DPBYTE_ORDER=PLITTLE_ENDIAN
+
+ ifeq (${OSARCH},Linux)
+@@ -47,7 +49,7 @@
+
+ # Pre Janus release directives
+ CFLAGS += -DNDEBUG -DDO_CRASH -DDEBUG_THREADS
+-CFLAGS += -pipe -Wall -fPIC
++CFLAGS += -pipe -Wall -fPIC $(OPTIMIZE)
+ ifeq (${OSARCH},Linux)
+ CFLAGS += -DP_LINUX
+ LIBS+=-lpthread
+@@ -74,7 +76,7 @@
+
+
+ libchanh323.a: ast_h323.o
+- ar cr libchanh323.a ast_h323.o
++ $(AR) cr libchanh323.a ast_h323.o
+
+ ast_h323.o: ast_h323.cpp
+ $(CXX) -g -c -fno-rtti -o $@ $(CFLAGS) $<