aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-23 19:49:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-23 19:49:19 +0000
commitfc7a57fa5d5105a8d4fe193a2401794ee361c7ea (patch)
treec4a5dc7b3b75b5717570464e0b8352097d7df109 /package/Makefile
parent1e8591f79be8a792cc4dd60589441fc44477824d (diff)
downloadmaster-187ad058-fc7a57fa5d5105a8d4fe193a2401794ee361c7ea.tar.gz
master-187ad058-fc7a57fa5d5105a8d4fe193a2401794ee361c7ea.tar.bz2
master-187ad058-fc7a57fa5d5105a8d4fe193a2401794ee361c7ea.zip
[buildsystem] use host opkg for installing packages in buildroot and ImageBuilder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22372 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/package/Makefile b/package/Makefile
index 5468bdc718..530405cd06 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -20,6 +20,9 @@ ifneq ($(IGNORE_ERRORS),)
$(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
endif
+$(curdir)/opkghost: $(TMP_DIR)/.build
+ @-$(MAKE) package/opkg/host/install
+
$(curdir)/install:=$(curdir)/install-cleanup
$(curdir)/cleanup: $(TMP_DIR)/.build
@@ -88,9 +91,10 @@ $(curdir)/index: FORCE
$(curdir)/flags-install:= -j1
$(eval $(call stampfile,$(curdir),package,prereq,.config))
-$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
-$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
-$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,cleanup))
+$(eval $(call stampfile,$(curdir),package,compile))
+$(eval $(call stampfile,$(curdir),package,opkghost))
+$(eval $(call stampfile,$(curdir),package,install,$(STAGING_DIR)/stamp/.package_opkghost))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
$(eval $(call subdir,$(curdir)))