aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-16 11:56:19 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-16 11:56:19 +0000
commita0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9 (patch)
tree5b8926dfc465868bbff96e7e131d2e4122bff9c9 /package/Makefile
parent420eec3ba8ff272511d476381734a65335999510 (diff)
downloadmaster-187ad058-a0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9.tar.gz
master-187ad058-a0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9.tar.bz2
master-187ad058-a0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9.zip
postinst trigger: the new postinst trigger broke IB
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42571 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile b/package/Makefile
index a42b4b0dd0..a6b34be0f4 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -59,6 +59,7 @@ endif
# where to build (and put) .ipk packages
OPKG:= \
+ IPKG_NO_SCRIPT=1 \
IPKG_TMP=$(TMP_DIR)/ipkg \
IPKG_INSTROOT=$(TARGET_DIR) \
IPKG_CONF_DIR=$(STAGING_DIR)/etc \
@@ -108,9 +109,8 @@ $(curdir)/install: $(TMP_DIR)/.build
@mkdir -p $(TARGET_DIR)/etc/rc.d
@( \
cd $(TARGET_DIR); \
- for script in ./etc/init.d/*; do \
- grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
- IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
+ for script in ./usr/lib/opkg/info/*.postinst; do \
+ IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) $$script; \
done || true \
)
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf