aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-05-07 16:45:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-05-07 16:45:00 +0000
commit9f1c5d418ade431e0eec7e49d4b5072f4bc2a61f (patch)
tree70e51ff16bcc04b359006678f8be524c171c8bc7 /package/Makefile
parentb25f25f063d3b1c42dc8b618eca825a35b84a521 (diff)
downloadmaster-187ad058-9f1c5d418ade431e0eec7e49d4b5072f4bc2a61f.tar.gz
master-187ad058-9f1c5d418ade431e0eec7e49d4b5072f4bc2a61f.tar.bz2
master-187ad058-9f1c5d418ade431e0eec7e49d4b5072f4bc2a61f.zip
add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11059 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index e618a90b69..a1f20b0b16 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -17,6 +17,9 @@ else
$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
$(curdir)/builddirs-install:=. $(sort $(package-y))
endif
+ifneq ($(IGNORE_ERRORS),)
+ $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+endif
$(curdir)/install:=$(curdir)/install-cleanup