aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-06-08 19:38:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-06-08 19:38:25 +0000
commit9ba991dcf1e1025d8fe22e7955211e13d79e22a0 (patch)
tree98ac5ae1a83b69adb679513b9db5c6b6bc866552 /package/Makefile
parente558a1dec9373aca5c3cc204174cb365c84f2af2 (diff)
downloadmaster-187ad058-9ba991dcf1e1025d8fe22e7955211e13d79e22a0.tar.gz
master-187ad058-9ba991dcf1e1025d8fe22e7955211e13d79e22a0.tar.bz2
master-187ad058-9ba991dcf1e1025d8fe22e7955211e13d79e22a0.zip
[package] make sure that base-files is installed last, this allows per-target base-file overlays to work correctly
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27138 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 4f2cbf106e..7d2c42d8b8 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -14,7 +14,7 @@ ifeq ($(SDK),1)
else
$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
- $(curdir)/builddirs-install:=. $(sort $(package-y))
+ $(curdir)/builddirs-install:=. $(filter-out base-files,$(sort $(package-y))) $(filter base-files,$(package-y))
endif
ifneq ($(IGNORE_ERRORS),)
$(curdir)/builddirs-ignore-compile:= $(if $(filter n m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(subst n,,$(m)))),$(package-m) $(package-))