aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 23:04:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 23:04:00 +0000
commit97eaa9e31ee443fc8e53a42466bdc6dd95f67989 (patch)
tree8a2b557729e41f1cbf43e6f4b2b03b54cbb0d7b8 /package/Makefile
parentb0ccfcae51b30279f589c3d647ce8d5cbadc0cf6 (diff)
downloadmaster-187ad058-97eaa9e31ee443fc8e53a42466bdc6dd95f67989.tar.gz
master-187ad058-97eaa9e31ee443fc8e53a42466bdc6dd95f67989.tar.bz2
master-187ad058-97eaa9e31ee443fc8e53a42466bdc6dd95f67989.zip
replace ipkg-make-index with a shell script that works on bsd
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5046 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index b6165b8567..d2b7468a39 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -9,6 +9,7 @@
include $(TOPDIR)/rules.mk
include $(TOPDIR)/.config
include $(TOPDIR)/.pkgdeps
+include $(TOPDIR)/host.mk
PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(package-prereq))
DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
@@ -58,7 +59,7 @@ install:
index: $(PACKAGE_DIR)/Packages
$(PACKAGE_DIR)/Packages: $(PACKAGE_DIR)/*.ipk
- (cd $(PACKAGE_DIR); $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages)
+ (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
ifeq ($(MAKECMDGOALS),compile-targets)