aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-04-17 12:50:30 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-04-17 12:50:30 +0000
commit901d82c08d74cde3610f972568506a5c86e4f81a (patch)
tree59684df8e9d050016739321f229089f80e2f2719 /package/Makefile
parent56c1ff672e3353cba42c931bbe4f12d9fad785b5 (diff)
downloadmaster-187ad058-901d82c08d74cde3610f972568506a5c86e4f81a.tar.gz
master-187ad058-901d82c08d74cde3610f972568506a5c86e4f81a.tar.bz2
master-187ad058-901d82c08d74cde3610f972568506a5c86e4f81a.zip
package: remove .git files from images
If you have your ./files/ directory stored in a git repository, the .git will be included into images using precious space. This patch removes .git directories before packing images. Signed-off-by: Joerg Jungermann <jj@borkum.net> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49180 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index c97e2c18d1..e0bd75ba7f 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -123,6 +123,7 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
$(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(TARGET_DIR)/usr/lib/opkg/status)
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name .svn | $(XARGS) rm -rf
+ @-find $(TARGET_DIR) -name .git | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst*
rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.prerm*