aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-07 15:35:12 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-07 15:35:12 +0000
commit8af50ca9215708eeb5a88394f5121c8b86c75b89 (patch)
treee1bc3d0fc19c4c1b147c9b488ab22fe95e8ea1a7 /package/Makefile
parenta02de007a40b36d7b17071b0fac80bb06d4c46df (diff)
downloadmaster-187ad058-8af50ca9215708eeb5a88394f5121c8b86c75b89.tar.gz
master-187ad058-8af50ca9215708eeb5a88394f5121c8b86c75b89.tar.bz2
master-187ad058-8af50ca9215708eeb5a88394f5121c8b86c75b89.zip
build: consider sub-directories when deploying packages to image with CONFIG_PER_FEED_REPO (#17430)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42041 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index bf1b16fc9a..0cba878576 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -94,7 +94,7 @@ $(curdir)/install: $(TMP_DIR)/.build
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
- @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
+ @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)$(if $(CONFIG_PER_FEED_REPO),/*)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
@for file in $(PACKAGE_INSTALL_FILES); do \
[ -s $$file.flags ] || continue; \
for flag in `cat $$file.flags`; do \