aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-09-19 23:06:12 +0000
committerNicolas Thill <nico@openwrt.org>2005-09-19 23:06:12 +0000
commit75225060ae3c3d1b820fda77bd3459c6ff638d27 (patch)
tree7c6373a3f2110bf1cfa1fbc561c4e13c5e49b2b5 /package/Makefile
parent3766660d7397a968087e2ce1624d63ce1b863859 (diff)
downloadmaster-187ad058-75225060ae3c3d1b820fda77bd3459c6ff638d27.tar.gz
master-187ad058-75225060ae3c3d1b820fda77bd3459c6ff638d27.tar.bz2
master-187ad058-75225060ae3c3d1b820fda77bd3459c6ff638d27.zip
enable all packages when DEVELOPER=1,
add curl and gmp extensions, fix gd extension build git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1948 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index ef6a712730..99447a8d3d 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -293,9 +293,15 @@ openvpn-compile: lzo-compile
endif
php4-compile: openssl-compile zlib-compile
+ifneq ($(BR2_PACKAGE_PHP4_MOD_CURL),)
+php4-compile: curl-compile
+endif
ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
php4-compile: libgd-compile libpng-compile
endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_GMP),)
+php4-compile: gmp-compile
+endif
ifneq ($(BR2_PACKAGE_PHP4_MOD_LDAP),)
php4-compile: openldap-compile
endif