aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-12-02 12:20:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-12-02 12:20:38 +0000
commit6acaf2e4703f43b7336ed75c49a5b03867cd724b (patch)
treeba2134f5b24e10578c017a43897227abeb2b1e64 /package/Makefile
parent0e9a69f081a7ac81e49efd3ceef6ca751443870f (diff)
downloadmaster-187ad058-6acaf2e4703f43b7336ed75c49a5b03867cd724b.tar.gz
master-187ad058-6acaf2e4703f43b7336ed75c49a5b03867cd724b.tar.bz2
master-187ad058-6acaf2e4703f43b7336ed75c49a5b03867cd724b.zip
package: use file_copy to deploy files/ in the package/install phase
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34438 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile10
1 files changed, 1 insertions, 9 deletions
diff --git a/package/Makefile b/package/Makefile
index eab3f85dd6..e88efdfe9f 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -89,15 +89,7 @@ $(curdir)/install: $(TMP_DIR)/.build
done || true
@-$(MAKE) package/preconfig
@if [ -d $(TOPDIR)/files ]; then \
- ( cd $(TOPDIR)/files; find -type f ) | \
- ( cd $(TARGET_DIR); while :; do \
- read FILE; \
- [ -z "$$FILE" ] && break; \
- [ -L "$$FILE" ] || continue; \
- echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
- rm -f "$$FILE"; \
- done; ); \
- $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
+ $(call file_copy,$(TOPDIR)/files/.,$(TARGET_DIR)); \
fi
@mkdir -p $(TARGET_DIR)/etc/rc.d
@( \