aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-02-23 22:59:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-02-23 22:59:57 +0000
commit610af758c1c0fe6a38a1fc8ee91dc95f1bb90b51 (patch)
tree2f5378ad21b1108b70673bc63ee81cb61faa9229 /package/Makefile
parent0081e14ade38823196a3cf1262292ce76cade22e (diff)
downloadmaster-187ad058-610af758c1c0fe6a38a1fc8ee91dc95f1bb90b51.tar.gz
master-187ad058-610af758c1c0fe6a38a1fc8ee91dc95f1bb90b51.tar.bz2
master-187ad058-610af758c1c0fe6a38a1fc8ee91dc95f1bb90b51.zip
[PATCH 2/2] Send ipkg-make-index.sh output to stdout
The "Generating index for package" created by ipkg-make-index only clutter stderr and serve to push previous warnings/errors off-screen. Instead, send to stdout. Note: This would send incorrect invocation messages to stdout as well. If this is a concern, perhaps we could send them to FD 3, then send 3 to 2... Signed-off-by: Kevin Locke <klocke@digitalenginesoftware.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25678 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 8e8c6c9a63..2180df3b37 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -89,7 +89,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
$(call mklibs)
$(curdir)/index: FORCE
- @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+ @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
gzip -9c Packages > Packages.gz \
)