aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-10 18:19:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-10 18:19:34 +0000
commit59003ac2c362a4ce5b26829f0928abfcde902510 (patch)
tree40d39f3925d64efe21af40a6ae0bb45322c5a106 /package/Makefile
parent7d7c3e5e0abe65c6c773231df1cc3e5da4582110 (diff)
downloadmaster-187ad058-59003ac2c362a4ce5b26829f0928abfcde902510.tar.gz
master-187ad058-59003ac2c362a4ce5b26829f0928abfcde902510.tar.bz2
master-187ad058-59003ac2c362a4ce5b26829f0928abfcde902510.zip
add asterisk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@611 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 743d2dfcdb..23fefcd0cc 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -6,6 +6,7 @@ package-y:=openwrt
package-$(BR2_PACKAGE_AICCU) += aiccu
package-$(BR2_PACKAGE_ARPTABLES) += arptables
package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
+package-$(BR2_PACKAGE_ASTERISK) += asterisk
package-$(BR2_PACKAGE_BRIDGE) += bridge
package-$(BR2_PACKAGE_BUSYBOX) += busybox
package-$(BR2_PACKAGE_BWM) += bwm
@@ -69,6 +70,15 @@ install: $(patsubst %,%-install,$(package-y))
ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
openvpn-compile: lzo-compile
endif
+ifneq ($(BR2_PACKAGE_ASTERISK_SPEEX),)
+asterisk-compile: speex-compile
+endif
+ifneq ($(BR2_PACKAGE_ASTERISK_PGSQL),)
+asterisk-compile: postgresql-compile
+endif
+ifneq ($(BR2_PACKAGE_ASTERISK_MYSQL),)
+asterisk-compile: mysql-compile
+endif
openswan-compile: gmp-compile
nocatsplash-compile: glib-compile