aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:13 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:13 +0000
commit509bbab11e6de6fed7973d1da74bc671737b9719 (patch)
treee457d9017747be595ee5c1c1523a90c0746a1efd /package/Makefile
parent032740230c3278e00e0691df46bbdffc848738e2 (diff)
downloadmaster-187ad058-509bbab11e6de6fed7973d1da74bc671737b9719.tar.gz
master-187ad058-509bbab11e6de6fed7973d1da74bc671737b9719.tar.bz2
master-187ad058-509bbab11e6de6fed7973d1da74bc671737b9719.zip
package/Makefile: Substituted deprecated -perm +mode with -perm /mode
The find(1) -perm +mode is no longer supported and has been deprecated since 2005. This could resolve #13855 ticket. Signed-off-by: Rocco Folino <lordzen87@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40927 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index e189e37043..1930d27cf8 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,7 +26,7 @@ ifdef CONFIG_USE_MKLIBS
define mklibs
rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
# first find all programs and add them to the mklibs list
- find $(STAGING_DIR_ROOT) -type f -perm +100 -exec \
+ find $(STAGING_DIR_ROOT) -type f -perm /100 -exec \
file -r -N -F '' {} + | \
awk ' /executable.*dynamically/ { print $$1 }' > $(TMP_DIR)/mklibs-progs
# find all loadable objects that are not regular libraries and add them to the list as well