aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-11 12:27:49 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-11 12:27:49 +0000
commit3caa9395b5c994b945767c8e528a2afdf24df35e (patch)
treed9ae4715ae0f048afe4f6bd6a501d7e9e00f34e1 /package/Makefile
parentca5a47c6d5778c5de8e3ed4bd3780bc19fae7fb3 (diff)
downloadmaster-187ad058-3caa9395b5c994b945767c8e528a2afdf24df35e.tar.gz
master-187ad058-3caa9395b5c994b945767c8e528a2afdf24df35e.tar.bz2
master-187ad058-3caa9395b5c994b945767c8e528a2afdf24df35e.zip
ipkg: add a default postinst/prerm script
the postinst script enables/starts the init.d scripts upon package installation and installs the users required by the package. the prerm script stops and disables the init.d scripts. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42470 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 0cba878576..a42b4b0dd0 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -116,7 +116,8 @@ $(curdir)/install: $(TMP_DIR)/.build
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name .svn | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
- rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst
+ rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst*
+ rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.prerm*
$(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)
$(call mklibs)